Chapter 5

Advanced Dimensioning Techniques and Base Feature Options

Learning Objectives

After completing this chapter, you will be able to:

• Fully define a sketch.
• Dimension the true length of an arc.
• Measure distances and view section properties
• Create solid base extruded features.
• Create thin base extruded features.
• Create solid base revolved features.
• Create thin base revolved features.
• Dynamically rotate the view to display the model from all directions.
• Modify the orientation of the view.
• Change the display modes of the solid models.
• Apply materials and textures to the models.
ADVANCED DIMENSIONING TECHNIQUES

In this chapter, you will learn about the advanced dimensioning techniques that are used to dimension the sketches. In SolidWorks, you can apply all possible relations and dimensions to a sketch using a single tool to make the sketch fully defined. The advanced dimensioning techniques are discussed next.

Fully Defining the Sketches

<table>
<thead>
<tr>
<th>Menu Bar:</th>
<th>Tools &gt; Dimensions &gt; Fully Define Sketch</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toolbar:</td>
<td>Dimensions/Relations &gt; Fully Define Sketch</td>
</tr>
</tbody>
</table>

The **Fully Define Sketch** tool is used to apply the relations and dimensions to the sketch automatically. To fully define a sketch, draw the sketch using the standard sketching tools. Choose **Fully Define Sketch** from the **Dimensions/Relations** toolbar; the **Fully Define Sketch PropertyManager** is displayed, as shown in Figure 5-1. You can also right-click and choose the **Fully Define Sketch** option from the shortcut menu to display this **PropertyManager**. Various rollouts in this **PropertyManager** are discussed next.

Entities to Fully Define

The **Entities to Fully Define** rollout is used to specify the entities to which the relations and dimensions need to be applied. The **All entities in sketch** radio button is selected by default. As a result, all entities drawn in the current sketching environment are selected to apply relations and dimensions. If you need to fully define only the selected entities, select the **Selected entities** radio button; the **Selected Entities to Fully Define** selection box will be displayed in the **Entities to Fully Define** rollout. Select the entities to be dimensioned using the select cursor; the names of the selected entities will be displayed in the **Selected Entities to Fully Define** selection box. If you select one or more entities before invoking the **Fully Define Sketch PropertyManager**, the **Selected entities** radio button will be selected by default. Also, the names of the selected entities will be displayed in the **Selected Entities to Fully Define** selection box. After specifying the other parameters, choose the **Calculate** button to calculate and place the required number of relations and dimensions to fully define the sketch.

Relations

The **Relations** rollout displays the buttons of all relations. You can choose all buttons or only those buttons that you want to apply to the sketch.
**Dimensions**

The **Dimensions** rollout is used to specify the type of dimensions to be applied, reference for the dimensions, and the placement of the dimensional value. The options in this rollout are discussed next.

**Horizontal Dimensions Scheme and Vertical Dimensions Scheme**

The **Horizontal Dimensions Scheme** and **Vertical Dimensions Scheme** drop-down lists in the **Dimensions** rollout are used to specify the dimensioning scheme to be applied to the horizontal and vertical dimensions in the sketch. The dimensioning schemes in this drop-down lists are discussed next.

**Chain**

The **Chain** option is used for the relative horizontal/vertical dimensioning of the sketch. When you invoke the **Fully Define Sketch PropertyManager** and select this option, the origin will be selected as the reference entity. This reference entity is used as a datum for generating dimensions. The name of the origin will be displayed in the **Datums - Vertical Model Edge, Model Vertex, Vertical Line or Point** selection box and the reference entity will be displayed in pink in the drawing area. You can also specify a user-defined reference entity after clicking in this selection box.

**Note**

*Chain dimensioning should be avoided if the tolerances relative to a common datum are required in the part.*

**Baseline**

The **Baseline** option is used for the absolute vertical/horizontal dimensioning of the sketch. In this dimensioning method, the dimensions are applied to the sketch with respect to the common datum. When you invoke the **Fully Define Sketch PropertyManager**, this option is selected by default. Also, the origin will be selected as the reference entity and will be used as a datum for generating dimensions. The name of the origin will be displayed in the **Datums - Vertical Model Edge, Model Vertex, Vertical Line or Point** selection box. You can also specify a user-defined reference entity.

**Ordinate**

The **Ordinate** option is used for the ordinate dimensioning of the sketch. When you invoke the **Fully Define Sketch PropertyManager** and select this option, a point or a vertical line will be selected as the reference entity and will be used as a datum for generating dimensions. The name of the selected reference entity will be displayed in the **Datums - Vertical Model Edge, Model Vertex, Vertical Line or Point** selection box and the reference entity will be displayed in pink in the drawing area. You can also specify a user-defined reference entity.

**Dimension placement**

The **Dimension placement** area is used to define the position where the generated dimensions will be placed. Four radio buttons are available in this area. The first is the **Above sketch** radio button and if you select this radio button, the horizontal
dimensions generated using the **Fully Define Sketch** tool will be placed above the sketch. The **Below sketch** radio button is selected by default and is used to place the dimensions below the sketch. The **Right of sketch** radio button is selected to place the dimensions on the right of the sketch. The **Left of sketch** radio button is selected to place the dimensions on the left of the sketch. This radio button is selected by default.

After specifying all parameters in the **Fully Define Sketch PropertyManager**, choose the **Calculate** button; the sketch will be fully defined. Next, choose the **OK** button or choose the **OK** icon from the confirmation corner. The relations and dimension, with the selected dimension scheme, will be applied to the sketch. Figure 5-2 shows the **Baseline** scheme with the origin as the datum. Figure 5-3 shows the **Ordinate** scheme with the origin as the datum.

**Figure 5-2** Baseline dimension created using the origin as the reference entity

**Figure 5-3** Ordinate dimension created using the origin as the reference entity

**Dimensioning the True Length of an Arc**

In SolidWorks, you can also apply the dimension of the true length of an arc, which is one of the advantages of the sketching environment of SolidWorks. To apply the dimension of the true length, invoke the **Smart Dimension** tool and select the arc using the dimension cursor; a radial dimension will be attached to the cursor. Move the cursor to any of the endpoints of the arc. When the cursor snaps the endpoint, use the left mouse button to specify the first endpoint of the arc; a linear dimension will be attached to the cursor. Move the cursor to the second endpoint of the arc and when the cursor snaps the endpoint, select it; a dimension will be attached to the cursor. Move the cursor to an appropriate place to place the dimension. The dimension of the true length of the arc is shown in Figure 5-4.

**Figure 5-4** Dimensioning the true length of an arc
MEASURING DISTANCES AND VIEWING SECTION PROPERTIES

In SolidWorks, you can measure the distance of the entities and view the section properties using various tools that are discussed next.

Measuring Distances

<table>
<thead>
<tr>
<th>CommandManager:</th>
<th>Evaluate &gt; Measure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menu Bar:</td>
<td>Tools &gt; Measure</td>
</tr>
<tr>
<td>Toolbar:</td>
<td>Tools &gt; Measure</td>
</tr>
</tbody>
</table>

The Measure tool is used to measure the perimeter, angle, radius, and distance between the lines, points, surfaces, and planes in sketches, 3D models, assemblies, or drawings. To measure an entity, invoke the Measure toolbar by choosing the Measure button from the Evaluate CommandManager; the Measure toolbar will be displayed. The name of the document in which you are working will be displayed at the top of the Measure toolbar, refer to Figure 5-5. Also, the current cursor will be replaced by the measure cursor. Select the entity or entities to be measured using the measure cursor; the result related to the selected element or elements will be displayed in a callout. You can also view the result in the Measure toolbar by expanding it. To expand the toolbar, choose the button with the down arrows on the right of the toolbar. The options in the Measure dialog box are discussed next.

![Figure 5-5 The Measure toolbar](image)

Arc/Circle Measurements

The Arc/Circle Measurements button is used to specify the technique of measuring the distance between the selected arcs or circles. When you choose the Arc/Circle Measurements button, a flyout will appear. The Center to Center option will be chosen by default in this flyout. So, the center-to-center distance will be measured when you select two arcs or circles. If you choose the Minimum Distance option from this flyout, the minimum tangential distance between the two selected arcs or circles will be measured. However, if you choose the Maximum Distance option from this flyout, the maximum tangential distance between the selected arcs or circles will be measured.

Units/Precision

The Units/Precision button is used to set the type of units and their precision. Choose this button; the Measure Units/Precision dialog box will be displayed. The Use document settings radio button is selected by default in this dialog box. The default units and precision of the
document are used while measuring the entities. You can also set the type of units and their precision for measuring the entities. To do so, select the Use custom settings radio button from this dialog box. The other options in this dialog box will be displayed, as shown in Figure 5-6. These options are discussed next.

Length unit Area
The Length unit area is used to set the units and the options of linear measurements of the entities. The Unit drop-down list is provided at the top left corner of the Length unit area. In this drop-down list, you can select any type of unit such as Angstroms, Nanometers, Microns, Millimeters, Centimeters, Meters, Microinches, Miles, Inches, Feet, and Feet and Inches. The other options in the Length unit area are discussed next.

Decimal places
This spinner is used to control the decimal places.

Decimal
The Decimal radio button is available only when you select the units as Microinches, Miles, Inches, or Feet and Inches from the Unit drop-down list. Select this radio button to display the dimension in the decimal form. You can also specify the decimal places using the Decimal places spinner provided on the right of the Decimal radio button.

Fractions
The Fractions radio button is available only when you select the units as Microinches, Miles, Inches, or Feet and Inches from the Units drop-down list. This radio button is selected to display the dimension in the fraction form. You can also set the value of the denominator by using the Denominator spinner provided on the right of the Fractions radio button.
Round to nearest fraction
The Round to nearest fraction check box is selected to display the value in fractions by rounding the value to the nearest fraction.

Scientific Notation
The Scientific Notation check box is selected to display the value in the scientific notation units.

Angular unit Area
The Angular unit area is used to set the units for the angular measurement. This area is provided with a drop-down list to specify the angular measurement units such as Degrees, Deg/Min, Deg/Min/Sec, and Radians. The Decimal places spinner is used to specify the decimal places.

Show XYZ Measurements
The Show XYZ measurements button is chosen by default in the Measure toolbar so the dx, dy, and dz values of the selected entities are displayed in the drawing area. If you deselect this button, only the minimum distance between the selected entities will be displayed.

XYZ Relative To
The XYZ Relative To button is used to define the coordinate system along which the selected entities will be measured. By default, the part origin is selected as the coordinate system. To select any other coordinate system that you created earlier, choose the XYZ Relative To button from the Measure toolbar; a flyout with all the coordinate systems that you have created along with the part origin will be displayed. Choose the coordinate system from this flyout. You will learn more about creating additional coordinate systems in the later chapters.

Projected On
The Projected On button is used to specify the location where the selected entity should be projected. You can project the selected entity on the screen or on a specific plane. The system will then calculate the measurement of the true projection. To specify the location, choose the Projected On button from the Measure toolbar; a callout will be displayed and you can select the location where you need to project the selected entity.

Determining Section Properties of Closed Sketches

<table>
<thead>
<tr>
<th>CommandManager:</th>
<th>Evaluate &gt; Section Properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menu Bar:</td>
<td>Tools &gt; Section Properties</td>
</tr>
<tr>
<td>Toolbar:</td>
<td>Tools &gt; Section Properties</td>
</tr>
</tbody>
</table>

The Section Properties tool enables you to determine the section properties of the sketch in the sketching environment or of the selected planar face in the Part mode and the Assembly mode. Remember that the section properties of only the closed sketches with nonintersecting closed loops can be determined. The section properties include the area, centroid relative to the sketch origin, centroid relative to the part origin, moment of inertia, polar moment of inertia, angle between the principle axes and sketch axes, and the principle moment of inertia.
To calculate the section properties, select a sketch or a face and then choose the Section Properties button from the Evaluate CommandManager; the Section Properties dialog box will be displayed, as shown in Figure 5-7.

![Section Properties dialog box](image)

*Figure 5-7  Resized view of the Section Properties dialog box*

When you invoke the Section Properties dialog box, a 3D triad will be placed at the centroid of the sketch. The section properties of the sketch are displayed in the Section Properties dialog box. The Selected items display box is used to display the name of the selected planar face or the sketch whose section properties are to be calculated. When you are in the Part mode, select the face to calculate the section properties and choose Recalculate to display the properties. To calculate the section properties of some other face, clear the previously selected face from the selection set and then, select the new face and choose the Recalculate button.

The Print button in the Section Properties dialog box is used to print the section properties. The Copy button is chosen to copy the section properties to the clip board from where you can copy them to a program such as MS Word. The rest of the options in this dialog box are similar to those discussed earlier.

**CREATING BASE FEATURES BY EXTRUDING SKETCHES**

<table>
<thead>
<tr>
<th>CommandManager:</th>
<th>Features &gt; Extruded Boss/Base</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menu Bar:</td>
<td>Insert &gt; Boss/Base &gt; Extrude</td>
</tr>
<tr>
<td>Toolbar:</td>
<td>Features &gt; Extruded Boss/Base</td>
</tr>
</tbody>
</table>

The sketches that you have drawn until now can be converted into base features by extruding the sketch using the Extruded Boss/Base tool from the Features CommandManager. After drawing the sketch, choose the Features tab from the CommandManager to display the Features CommandManager. Choose the Extruded
Boss/Base button from the Features CommandManager; the sketching environment will be closed and the part modeling environment will be invoked. Also, the preview of the feature that is created using the default options will be displayed in the trimetric view. The trimetric view gives a better display of the solid feature.

On the basis of the options and the sketch selected for extruding, the resulting feature can be a solid feature or a thin feature. If the sketch is closed, it can be converted into a solid feature or a thin feature. However, if the sketch is open, it will be converted into a thin feature. The solid and thin features are discussed next.

Creating Solid Extruded Features
After you have completed drawing a closed sketch, dimension it to convert the sketch into a fully defined sketch. Next, choose the Features tab above the FeatureManager design tree; the Features CommandManager will be displayed. Then, choose the Extruded Boss/Base button; the Extrude PropertyManager will be displayed, as shown in Figure 5-8. Also, you will notice that the view is automatically changed to the trimetric view.

Figure 5-8 The Extrude PropertyManager

You will notice that the preview of the base feature is displayed in temporary graphics. Also, an arrow will appear in front of the sketch. Note that if the sketch consists of some closed

Tip. If you extrude an underdefined sketch, a (-) sign will be displayed on the left of the sketch in the FeatureManager. Similarly, if you extrude an overdefined sketch, you will find a (+) sign on the left of the sketch in the FeatureManager. To check these signs, click on the (+) sign available on the left of Extrude 1 in the FeatureManager; the sketch will be displayed and you can view the (+) sign or the (-) sign.
loops inside the outer loop, they will automatically be subtracted from the outer loop while extruding, as shown in Figure 5-9.

![Figure 5-9 Preview of the feature being extruded](image)

The options in the **Extrude PropertyManager** are discussed next.

**Direction 1**

The **Direction 1** rollout is used to specify the end condition for extruding the sketch in one direction from the sketch plane. The options in the **Direction 1** drop-down list are discussed next.

**End Condition**

The **End Condition** drop-down list provides the options to define the termination of the extruded feature. Note that when you create the first feature, some of the options in this drop-down list will not be used. Also, some additional options will be available later in this drop-down list. The options that will be used to define the termination of the base feature are discussed next.

**Blind**

The **Blind** option is selected by default and is used to define the termination of the extruded base feature by specifying the depth of extrusion. The depth of extrusion is specified in the **Depth** spinner that will be displayed in the **Direction 1** rollout on selecting the **Blind** option. To reverse the extrusion direction, select the **Reverse Direction** button provided on the left of this drop-down list. Figure 5-10 shows the preview of the feature being created by extruding the sketch using this option.

You can also extrude a sketch to a blind depth by dragging the feature dynamically using the mouse. To do so, move the mouse to the arrow displayed in the preview; the move cursor will be displayed and the color of the arrow will also be changed. Left-click once on the arrow; a scale will be displayed, as shown in Figure 5-11. Now, move the cursor to specify the depth of extrusion; the value of the depth of extrusion will change dynamically on this scale as you move the cursor. Left-click again to specify the termination of the extruded feature. The select cursor will be replaced by the mouse cursor. Right-click and choose **OK** to complete the feature creation or choose the **OK** button from the **Extrude PropertyManager**.
Mid Plane
The Mid Plane option is used to create the base feature by extruding the sketch equally in both the directions of the plane on which the sketch is drawn. For example, if the total depth of the extruded feature is 30 mm, it will be extruded 15 mm toward the front of the sketching plane and 15 mm toward the back. The depth of the feature can be defined in the Depth spinner that is displayed below the Direction of Extrusion selection box.

Figure 5-12 shows the preview of the feature being created by extruding the sketch using the Mid Plane option.

Draft On/Off
The Draft On/Off button is used to specify a draft angle while extruding the sketch. Apply the draft angle to taper the resulting feature. This button is not chosen by default. Therefore, the resulting base feature will not have any taper. However, if you want to add a draft angle to the feature, choose this button; the Draft Angle spinner and the Draft outward check box will be available. You can enter the draft angle for the
feature in the Draft Angle spinner. By default, the feature will be tapered inward, as shown in Figure 5-13.

If you want to taper the feature outward, select the Draft outward check box, which is displayed below the Draft Angle spinner. The feature created with the outward taper is shown in Figure 5-14.

![Figure 5-13 Feature created with inward draft](image1)

![Figure 5-14 Feature created with outward draft](image2)

**Note**
The Direction of Extrusion area will be discussed in the later chapters.

**Tip.** You can also choose the termination options using the shortcut menu that is displayed when you right-click in the drawing area.

**Direction 2**
The Direction 2 check box is selected to expand the Direction 2 rollout. This rollout is used to extrude the sketch with different values in the second direction of the sketching plane. This check box will not be available if you select the Mid Plane termination type.

**Tip.** As soon as you select the Direction 2 check box, another arrow will be displayed in the preview of the feature. You can use this arrow to define the depth of extrusion in the second direction.

The options in this rollout are similar to those in the Direction 1 rollout. Note that unlike the Mid Plane termination option, the depth of extrusion and other parameters in both directions can be different. For example, you can extrude the sketch to a blind depth of 10 mm and an inward draft of 35-degrees in front of the sketching plane and to a blind depth of 15 mm and an outward draft of 0-degree behind the sketching plane, as shown in Figure 5-15.
After setting the values for both directions, choose the OK button or choose the OK icon from the confirmation corner; the feature will be created with the defined values.

**Note**

*The Selection Contours rollout will be discussed in the later chapters.*

**Creating Thin Extruded Features**

The thin extruded features can be created using a closed or an open sketch. If the sketch is closed, the thickness will be specified inside or outside the sketch to create a cavity inside the feature, as shown in Figure 5-16. To convert a closed sketch into a thin feature, choose the Thin Feature check box; the Thin Feature rollout will be invoked, as shown in Figure 5-17.

The options in the Thin Feature rollout of the Extrude PropertyManager are discussed next.

**Type**

The options provided in the Type drop-down list are used to select the method of defining the thickness of the thin feature. These options are discussed next.
One-Direction
The One-Direction option is used to add the thickness on one side of the sketch. The thickness can be specified in the Thickness spinner provided below the Type drop-down list. For the closed sketches, the direction can be inside or outside the sketch. Similarly, for open sketches, the direction can be below or above the sketch. You can reverse the direction of thickness using the Reverse Direction button available on the left of the Type drop-down list. This button will be available only when you select the One-Direction option from this drop-down list.

Mid-Plane
The Mid-Plane option is used to add the thickness equally on both sides of the sketch. The value of the thickness of the thin feature can be specified in the Thickness spinner provided below this drop-down list.

Two-Direction
The Two-Direction option is used to create a thin feature by adding different thicknesses on both sides of the sketch. The thickness values in direction 1 and direction 2 can be specified in the Direction 1 Thickness spinner and the Direction 2 Thickness spinner, respectively. These spinners will automatically be displayed below the Type drop-down list when you select the Two-Direction option from this drop-down list.

Cap ends
The Cap ends check box will be displayed only when you select a closed sketch to convert into a thin feature. This check box is selected to cap the two open faces of the thin extruded feature. Both open faces will be capped with a face of the thickness that you specify. When you select this check box, the Cap Thickness spinner will be displayed below this check box. The thickness of the end caps can be specified using this spinner.

If the sketch to be extruded is open, as shown in Figure 5-18, the Thin Feature rollout will be invoked automatically when you invoke the Extrude PropertyManager. The resulting feature is shown in Figure 5-19.

Figure 5-18  Open sketch to be converted into a thin feature
Figure 5-19  Resulting thin feature
**Auto-fillet corners**

The Auto-fillet corners check box will be displayed only when you select an open sketch to convert into a thin feature. If you select this check box, all sharp vertices in the sketch will automatically be filleted while converting into a thin feature. As a result, the thin feature will have filleted edges. The radius of the fillet can be specified in the Fillet Radius spinner, which will be displayed below the Auto-fillet corners check box.

Figure 5-20 shows the thin feature created by extruding an open sketch in both directions. Note that a draft angle is applied to the feature while extruding in the front direction and the Auto-fillet corners check box is selected while creating this thin feature.

![Figure 5-20 Thin feature created in both directions](image)

**Note**

Only the corners of the thin features that can accommodate to the given radius will be filleted; other corners that cannot accommodate to the given radius will not be filleted.

### CREATING BASE FEATURES BY REVOLVING SKETCHES

<table>
<thead>
<tr>
<th>CommandManager:</th>
<th>Features &gt; Revolved Boss/Base</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menu Bar:</td>
<td>Insert &gt; Boss/Base &gt; Revolve</td>
</tr>
<tr>
<td>Toolbar:</td>
<td>Features &gt; Extruded Boss/Base &gt; Revolved Boss/Base</td>
</tr>
</tbody>
</table>

The sketches that you have drawn until now can also be converted into base features by revolving using the Revolved Boss/Base tool. This tool is available in the Features CommandManager. Choose this tool to revolve the sketch about a revolution axis. The revolution axis could be an axis, an entity of the sketch, or an edge of another feature to create the revolved feature. Note that whether you use a centerline or an edge to revolve the sketch, the sketch should be drawn on one side of the centerline or the edge.

In SolidWorks, the right-hand thumb rule is followed while determining the direction of revolution. The right-hand thumb rule states that if the thumb of your right hand points in the direction of the axis of revolution, the direction of the curled fingers will determine the default direction of revolution, refer to Figure 5-21.
For example, consider a case in which you draw a centerline from left to right (direction of thumb in Figure 5-21) in the drawing area. Now, if you use this centerline to create a revolved feature, the default direction of revolution will be in the direction of the curled fingers.

**Note**
You can also reverse the direction of revolution using the *Reverse Direction* button in the *Revolve PropertyManager*.

Invoke the *Revolved Boss/Base* tool after drawing the sketch; the sketching environment is closed and the part modeling environment is invoked. Similar to extruding the sketches, the resulting feature can be a solid feature or a thin feature, depending on the sketch and the options selected to be revolved. If the sketch is closed, it can be converted into a solid feature or a thin feature. However, if the sketch is open, it can be converted only into a thin feature. The solid and thin features are discussed next.

### Creating Solid Revolved Features
After you have completed drawing a closed sketch, dimension it to convert it into a fully defined sketch. Next, choose the *Features* tab above the *FeatureManager design tree*; the *Features CommandManager* will be displayed. Then, choose the *Revolved Boss/Base* button; the *Revolve PropertyManager* will be displayed, as shown in Figure 5-22. Also, the confirmation corner will be displayed and the preview of the base feature, created using the default options, will be displayed in temporary shaded graphics. The direction arrow will also be displayed in gray. If you have not drawn the centerline, you will be prompted to select an axis of revolution. Select an edge or a line as the axis of revolution; the preview will be displayed. The options in the *Revolve Parameters* rollout of the *Revolve PropertyManager* are discussed next.

**Tip.** Even though you can revolve the sketch using an edge in the sketch, it is recommended to draw a centerline, so that you can create linear diameter dimensions for the revolved features.
Revolve Type

The Revolve Type drop-down list provides the options to define the termination of the revolved feature. The options in this drop-down list are discussed next.

One-Direction

The One-Direction option is used to revolve the sketch on one side of the plane on which it is drawn. The angle of revolution can be specified in the Angle spinner displayed below this drop-down list. The default value in the Angle spinner is 360°. Therefore, if you revolve the sketch using this value, a complete round feature will be created. You can also reverse the direction of revolution of the sketch by choosing the Reverse Direction button that is displayed on the left of the drop-down list. Figure 5-23 shows the sketch of the piston and Figure 5-24 shows the resulting piston created by revolving the sketch through an angle of 360-degrees. Note that the left vertical edge of the sketch that is vertically in line with the origin is used to revolve the sketch.

Tip. You can dynamically modify the angle in a revolved feature by dragging the direction arrows. You can also right-click to display the shortcut menu. The options in the PropertyManager will be available in the shortcut menu.
Figure 5-25 shows a piston created by revolving the same sketch through an angle of
270-degrees.

![Feature created by revolving the sketch through an angle of 270-degrees](image)

**Mid-Plane**

The *Mid-Plane* option is used to revolve the sketch equally on both sides of the plane on
which it is drawn. The angle of revolution can be specified in the *Angle* spinner. When
you select this option, the *Reverse Direction* button will not be available.

**Two-Direction**

The *Two-Direction* option is used to create a revolved feature by revolving the sketch
using different values on both sides of the plane on which it is drawn. The angle values
for direction 1 and direction 2 can be specified in the *Direction 1 Angle* spinner and the
*Direction 2 Angle* spinner, respectively. These spinners will be displayed below the *Revolve
Type* drop-down list automatically when you select the *Two-Direction* option from this
drop-down list.

**Creating Thin Revolved Features**

The thin revolved features can be created using the closed or the open sketches. If the sketch
is closed, it will be offset inside or outside to create a cavity inside the feature as shown in
Figure 5-26. In this figure, the sketch is revolved through an angle of 180-degrees.

To convert a closed sketch into a thin feature, select the *Thin Feature* check box from the
*Revolve PropertyManager*; the *Thin Feature* rollout will be invoked, as shown in Figure 5-27.
However, if the sketch to be revolved is open and you invoke the *Revolved Boss/Base* tool,
the *SolidWorks* information box will be displayed. This information box will inform you that
the sketch is currently open and a non-thin revolved feature requires a closed sketch. You will
be given an option of automatically closing the sketch. If you choose *Yes* from this information
box, a line segment will automatically be drawn between the first and the last segment of the
sketch and the *Revolve PropertyManager* will be displayed. However, if you choose *No*
from this information box, the *Revolve PropertyManager* will be displayed and the *Thin Feature*
rollout will be displayed automatically.
The options in the **Thin Feature** rollout of the **Revolve PropertyManager** are discussed next.

**Type**
The options in the **Type** drop-down list are used to select a method to specify the thickness of the thin feature. These options are discussed next.

**One-Direction**
The **One-Direction** option is used to add the thickness on one side of the sketch. The thickness can be specified in the **Direction 1 Thickness** spinner provided below this drop-down list. For the closed sketches, the direction can be inside or outside the sketch. Similarly, for open sketches, the direction can be below or above the sketch. You can reverse the direction of thickness using the **Reverse Direction** button available on the right of this drop-down list. This button will be available only when you select the **One-Direction** option from this drop-down list.

**Mid-Plane**
The **Mid-Plane** option is used to add the thickness equally on both sides of the sketch. The value of the thickness of the thin feature can be specified in the **Direction 1 Thickness** spinner provided below this drop-down list.

**Two-Direction**
The **Two-Direction** option is used to create a thin feature by adding different thicknesses on both sides of the sketch. The thickness values for direction 1 and direction 2 can be specified in the **Direction 1 Thickness** spinner and the **Direction 2 Thickness** spinner, respectively. These spinners will be displayed below the **Type** drop-down list automatically when you select the **Two-Direction** option from this drop-down list.

**Tip.** While defining the wall thickness of a thin revolved feature, remember that the wall thickness should be added such that the centerline does not intersect with the sketch. If the centerline intersects with the sketch, the sketch will not be revolved.
If the sketch is open, as shown in Figure 5-28, the resulting feature will be similar to that shown in Figure 5-29.

**Figure 5-28** The open sketch to be revolved and the centerline to revolve the sketch

**Figure 5-29** Thin feature created by revolving the open sketch through an angle of 180-degrees

## DYNAMICALLY ROTATING THE VIEW OF THE MODEL

In SolidWorks, you can dynamically rotate the view in the 3D space so that the solid models in the current document can be viewed from all directions. This allows you to visually maneuver around the model to view all the features clearly. This tool can be invoked even when you are inside some other tool. For example, you can invoke this tool when the *Extrude Feature* dialog box is displayed. You can freely rotate the model in the 3D space or rotate it around a selected vertex, edge, or face. Both methods of rotating the model are discussed next.

### Rotating the View Freely in 3D Space

To rotate the view freely in the 3D space, choose the *Rotate View* button from the *Heads-up View* toolbar. You can also invoke this tool by choosing the *Rotate View* option from the shortcut menu that will be displayed when you right-click in the drawing area. When you are inside some other tool, right-click and choose the *Zoom/Pan/Rotate > Rotate View* from the shortcut menu to invoke the *Rotate View* tool. When you invoke this tool, the cursor will be replaced by the rotate view cursor. Now, press the left mouse button and drag the cursor to rotate the view. Figure 5-30 shows the rotated view of the model.

### Rotating the View Around a Selected Vertex, Edge, or Face

To rotate the view around a vertex, edge, or face, invoke the *Rotate View* tool and move the rotate view cursor close to the vertex, edge, or the face around which you want to rotate the view. When it is highlighted, select it using the left mouse button; the rotate view cursor will be displayed, as shown in Figure 5-31. Next, drag the cursor to rotate the view around the selected vertex, edge, or face.
MODIFYING THE VIEW ORIENTATION

In SolidWorks, you can manually change the view orientation using some predefined standard views or user-defined views. To invoke these standard views, choose the View Orientation button from the Heads-up View toolbar; a flyout will be displayed, as shown in Figure 5-32.

**Figure 5-32** The View Orientation flyout
You can choose the required view from this flyout and orient the model to standard views. You need to choose the **Normal To** option to reorient the view normal to a selected face or plane. To do so, select the face normal to which you need to reorient the model and choose the **Normal To** option from this flyout. If you have not selected a face before choosing this option, the **Normal To PropertyManager** will be displayed and you will be prompted to select a reference along which the view will be reoriented. In SolidWorks 2008, you can select the **Normal To** option from the pop-up toolbar also, this toolbar will be displayed on selecting an entity.

You can also invoke these standard views using the **Orientation** dialog box, as shown in Figure 5-33. This dialog box can be invoked by choosing **Zoom/Pan/Rotate > View Orientation** from the shortcut menu or by pressing the SPACEBAR on the keyboard. Note that when you invoke this dialog box by pressing the SPACEBAR, the dialog box will be displayed at the location where the cursor is placed currently.

You can invoke a view by double-clicking on the name of the view in this dialog box. The buttons available on this dialog box are discussed next.

**Push-Pin**

You will notice that the **Orientation** dialog box is automatically closed when you select a view and click on the screen or invoke a tool. If you want this dialog box to be retained on the screen, you can pin it at a location by choosing the **Push-Pin** button. This is the first button on this dialog box. Move the dialog box to the desired location and choose this button; the dialog box will be pinned to that location and will not be closed when you perform any operation.

**New View**

The **New View** button is chosen to create a user-defined view and save it in the list of views in the **Orientation** dialog box. Modify the current view using the various drawing display tools and the **Rotate View** tool and then choose this button; the **Named View** dialog box will be displayed. Enter the name of the view in the **View name** edit box and then choose the **OK** button. You will notice that a user-defined view is created and it is saved in the list in the **Orientation** dialog box.

**Update Standard Views**

The **Update Standard Views** button is chosen to modify the orientation of the standard views. For example, when you select the **Top** option from this dialog box, the top view of a model will be displayed. If you want to make this view as the front view, change the current view to the top view. To do so, double-click on the **Top** option in the **Orientation** dialog box. Now, select the **Front** option from the list of views available in the **Orientation** dialog box and then choose the **Update Standard Views** button. The **SolidWorks** message box will be displayed and you will be informed that if you change the standard view, all other named views in the model will also be changed. Choose the **Yes** button; the views are modified. You will notice that the view that was originally displayed as the top view is now displayed as the front view. Also, all other views will be modified accordingly.
Reset Standard Views

The Reset Standard Views button is chosen to reset the standard settings of all standard views in the current drawing. When you choose this button, the SolidWorks warning box will be displayed and you will be prompted to confirm whether you want to reset all standard views to their original settings or not. If you choose Yes, all the standard views will be reset to their default settings.

RESTORING PREVIOUS VIEW

While working on a model, you need to temporarily change the view of the model to view it from different directions. Once you have finished editing or viewing the model in the current view, choose the Previous View button in the Heads-up View toolbar to restore the previous view. This tool saves ten previous views of the model.

DISPLAYING THE DRAWING AREA IN VIEWPORTS

In SolidWorks, you can display the drawing area in multiple viewports. The procedure to do so is discussed next.

Displaying the Drawing Area in Two Horizontal Viewports

Menu Bar: Window > Viewport > Two View - Horizontal
Toolbar: Heads-up View > View Orientation > Two View - Horizontal

The Two View - Horizontal option is used to split the drawing view to display the model in two viewports that are placed horizontally. To do so, choose View Orientation > Two View - Horizontal from the Heads-up View toolbar; the drawing area will be divided into two rows. Figure 5-34 shows the model placed in the top orientation in the upper row and in the front orientation in the lower row. The type of orientation of both the models is displayed on the lower left corner of each viewport.

To switch back to the single viewport, choose View Orientation > Single View from the Heads-up View toolbar or choose Window > Viewport > Single View in the Menu Bar menus.

Displaying the Drawing Area in Two Vertical Viewports

Menu Bar: Window > Viewport > Two View - Vertical
Toolbar: Heads-up View > View Orientation > Two View - Vertical

The Two View - Vertical button is used to split the drawing view to display the model in two viewports that are placed vertically. To display the model in this fashion, choose View Orientation > Two View - Vertical from the Heads-up View toolbar; the drawing area will be divided into two columns placed vertically. Figure 5-35 shows the model placed in the front orientation in the left column and in the right orientation in the right column.

Tip. On creating multiple viewports, you will notice that the Heads-up View toolbar will be available in the currently active viewport. To activate another viewport, click once in the drawing area in that viewport.
Displaying the Drawing Area in Four Viewports

Menu Bar: Window > Viewport > Four View
Toolbar: Heads-up View > View Orientation > Four View

The Four View option is used to split the drawing view to display the model in four viewports, as shown in Figure 5-36. To display the model in this fashion, choose View Orientation > Four View from the Heads-up View toolbar; the drawing area will be divided into four parts. The model is placed in the front, top, right, and trimetric orientations in these four viewports. The type of orientation of all models is displayed at the lower left corner of each viewport.
DISPLAY MODES OF THE MODEL

SolidWorks provides you with various predefined modes to display the model. In SolidWorks 2008, the display modes are grouped together in the **Display Style** tool. To invoke a tool, choose the **Display Style** button from the Heads-up View toolbar; a flyout consisting of tools that are used for various display modes will be displayed. Choose any of the display modes. These modes are discussed next.

**Wireframe**

When you choose the **Wireframe** button, all hidden lines will be displayed along with the visible lines in the model. Sometimes it becomes difficult to recognize the visible lines and the hidden lines if you set this display mode for complex models.

**Hidden Lines Visible**

When you choose the **Hidden Lines Visible** button, the model will be displayed in wireframe and the hidden lines in the model will be displayed as dashed lines.

**Hidden Lines Removed**

When you choose the **Hidden Lines Removed** button, the hidden lines in the model will not be displayed. Only the edges of the faces visible in the current view of the model will be displayed.

**Shaded With Edges**

The **Shaded With Edges** mode is the default mode in which the model is displayed. In this display mode, the model is shaded and the edges of the visible faces of the model are displayed.

**Shaded**

This display mode is similar to the **Shaded With Edges** mode the only difference is that the edges of the visible faces will not be displayed.

Tip. Sometimes when you rotate the view of an assembly or a model having large number of features in the **Shaded** or the **Hidden Lines Removed** shading modes, the regeneration of the model takes a lot of time. This can be avoided by choosing the **Draft Quality HLR/HLV** button combined with the other shading modes. This button is not available by default, therefore, you need to customize a toolbar or a **CommandManager**. On choosing this button, you can speed up the regeneration time and easily rotate the view. This is a toggle mode and is turned on when you choose this button.
ADDITIONAL DISPLAY MODES
In addition to the standard display modes discussed earlier, you can also display a model in the shaded mode, or view a model in the perspective view. The tools for displaying these views are available in the Heads-up View toolbar. These tools are discussed next.

Shadows In Shaded Mode

The Shadows In Shaded Mode button is used to display the shadow of a model. A light appears from the top of the model to display the shadow in the current view. With this option activated, the performance of the system is affected during the dynamic orientation. Remember that the position of the shadow is not changed when you rotate the model in the 3D space. To change the placement of the shadow, first remove the shadow in the shaded model using the Shadows In Shaded Mode button and rotate the model. After rotating the model, use the same button to activate the shadow in the shaded mode. Figure 5-37 shows a T-section in the shadow in the shaded mode.

Perspective

You can display the perspective view of a model by choosing View Settings > Perspective from the Heads-up View toolbar. Figure 5-38 shows the T-section with shadow in the perspective view. You can also modify the settings of the perspective view. To modify the settings, choose View > Modify > Perspective from the Menu Bar menus; the Perspective View PropertyManager will be displayed. Use the Object Sizes Away spinner of this PropertyManager to modify the observer’s position.

Tip. You can also save a perspective view as a named view. To do this, invoke the perspective view and define the orientation by rotating the view. Press the SPACEBAR to invoke the Orientation dialog box. Choose the New View button and specify the name of the view in the Named View dialog box.
ASSIGNING MATERIALS AND TEXTURES TO THE MODELS

You can assign materials and textures to models. When you apply a material to a model, the physical properties such as density, Young’s modulus, and so on will be assigned to the model. When you apply a texture to a model or its face, the image of that texture will be applied to the model or its selected face. Physical properties are not applied to the model when you apply the texture. The method to assign materials and textures is discussed next.

Assigning Materials to the Model

<table>
<thead>
<tr>
<th>Toolbar:</th>
<th>Standard &gt; Edit Material</th>
<th>(Customize to add)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menu Bar:</td>
<td>Edit &gt; Appearance &gt; Material</td>
<td></td>
</tr>
</tbody>
</table>

Whenever you assign a material to a model, all physical properties of the selected material are also assigned to the model. As a result, when you calculate the mass properties of the model, they will be based on the physical properties of the material applied. To assign a material to a model, choose the **Edit Material** button from the **Standard** toolbar; the **Materials Editor PropertyManager** will be displayed, as shown in Figure 5-39. You can also right-click on the **Material <not specified>** option in the **FeatureManager design tree** to invoke the **Materials Editor PropertyManager**.

![Figure 5-39 Partial display of the Materials Editor PropertyManager](image)

A number of material families are available in the **Materials rollout**. Click on the (+) sign located on the left of the material family to display all materials under that family. Select the material from that family.
Assigning Textures to the Model

You can assign a texture to a model, feature, or a selected face. To do so, invoke the Edit Texture tool; the Texture PropertyManager will be displayed, as shown in Figure 5-40. In SolidWorks 2008, you can also invoke the Texture PropertyManager through another method. In this method, you first need to select a face; a pop-up toolbar will be displayed. Now, choose the Appearance Callout button from this toolbar; a flyout will be displayed with the name of the face, feature, and part. Choose the check mark corresponding to the Texture; the Texture PropertyManager will be displayed.

The Selection rollout has some buttons on the left. These buttons are the filters for making a selection to assign the textures. For example, if you want to assign the texture on a face of the model, choose the Select Faces button and clear all the remaining buttons. This allows you to select only a specified face. You can select the required face from the model. The selected face or model will be displayed in the Selected Entities area of the Selection rollout.

Various texture families that can be selected are available in the Texture Tree area of the Texture Selection rollout. Click on the (+) sign located on the left of a texture family to select a texture of that family. Figure 5-41 shows a model with the Gravel type of stone applied to its top face.

Figure 5-40  The Texture PropertyManager

Figure 5-41  A model with the Gravel type of stone applied to its top face.
The preview of the selected texture will be displayed on the model or the face and also in the Texture Preview area of the Texture Properties rollout. You can use the Scale and Angle sliders in this rollout to change the scale and angle of the selected texture.

You can remove the texture applied to a face or a model by choosing the Remove Textures button available below the Selected Entities area in the Selection rollout.

The drop-down list available below the Texture Tree area in the Texture Selection rollout lists the last ten textures used. You can also select a texture from this drop-down list.

**TUTORIALS**

**Tutorial 1**

In this tutorial, you will open the sketch drawn in Tutorial 3 of Chapter 4. You will then convert that sketch into an extruded model by extruding it in two directions, as shown in Figure 5-42. The parameters for extruding the sketch are given next.

**Direction 1**
Depth = 10 mm
Draft angle = 35-degrees

**Direction 2**
Depth = 15 mm
Draft angle = 0-degree

After creating the model, you will rotate the view using the Rotate View tool and then modify the standard views such that the front view of the model becomes the top view. You will then save the model with the current settings.

(Expected time: 30 min)
The steps required to complete this tutorial are as follows:

a. Open the document of Tutorial 3 of Chapter 4, refer to Figure 5-43.
b. Save this document in the \c05 folder with a new name.
c. Invoke the Extruded Boss/Base tool and convert the sketch into a model, refer to Figures 5-44 and 5-45.
d. Rotate the view using the Rotate View tool to view the model from all directions, refer to Figure 5-46.
e. Invoke the Orientation dialog box and then modify the standard view, refer to Figure 5-47.

Opening the Document of Tutorial 3 of Chapter 4

As the required document is saved in the \c04 folder, you need to select this folder and then open the c04tut3.sldprt document.

1. Start SolidWorks 2008 by double-clicking on its shortcut icon on the desktop of your computer.

2. Choose the Open a Document option from the SolidWorks Resources task pane to display the Open dialog box.

3. Browse and select the c04 folder.

4. Select the c04tut3.sldprt document and then choose the Open button. Close the SolidWorks Resources task pane.

As the sketch was saved in the sketching environment in Chapter 4, it is opened in the sketching environment.

Saving the Document in the c05 Folder

It is recommended that when you open a document of some other chapter, you should save it in the folder of the current chapter with some other name before modifying the
document. This is because if you save the document in the folder of the current chapter, the original document of the other chapter will not get modified.

1. Choose **File > Save As** from the Menu Bar menus; the **Save As** dialog box is displayed.

As the `c04` folder was selected last to open the document, it will be the current folder.

2. Choose the **Up One Level** button available on the right of the **Save in** drop-down list and move to the `\SolidWorks` folder. Create a new folder with the name `c05` using the **Create New Folder** button. Make the `c05` folder as current by double-clicking on it.

3. Enter the new name of the document as `c05tut1` in the **File name** edit box and then choose the **Save** button to save the document.

The document is saved with the new name and is now opened in the drawing area, as shown in Figure 5-43.

![Figure 5-43 Sketch that will open in the drawing area](image)

**Extruding the Sketch**

Next, you need to invoke the **Extruded Boss/Base** tool and extrude the sketch using the parameters given in the tutorial description.

1. Choose the **Features** tab above the **FeatureManager design tree** to display the **Features CommandManager**. Choose the **Extruded Boss/Base** button; the sketch is automatically oriented to the trimetric view and the **Extrude PropertyManager** is displayed, as shown in Figure 5-44.

As you are converting the closed sketch into a feature, only the **Direction 1** rollout is displayed in the **Extrude PropertyManager**. Also, the preview of the feature is displayed in the temporary shaded graphics with the default values.
2. Choose the Draft On/Off button from the Direction 1 rollout and then set the value of the Draft Angle spinner to 35.

These are the settings for direction 1. Next, you need to specify the settings for direction 2.

3. Select the Direction 2 check box to invoke the Direction 2 rollout.

   You will notice that the default values in this rollout are the same as you specified in the Direction 1 rollout.

4. Choose the Draft On/Off button in the Direction 2 rollout to turn this option off. This is because you do not require the draft angle in the second direction.

5. Set the value in the Depth spinner to 15 as the depth in the second direction is 15 mm.

6. Choose the OK button to create the feature or choose OK from the confirmation corner.

   It is recommended that you change the view to isometric after creating the feature so that you can view the feature properly.

7. Choose the View Orientation button from the Heads-up View toolbar; a flyout is displayed. Then, choose Isometric from it. If the origin is displayed, turn off the display of the origin in the model by choosing Hide/Show Items > View Origins from the Heads-up View toolbar. The isometric view of the resulting solid model is shown in Figure 5-45.
Rotating the View

As mentioned earlier, you can rotate the view so that you can view the model from all directions.

1. Press the middle mouse button and move the cursor; the arrow cursor is replaced by the rotate view cursor.

2. Press and hold the middle mouse button and drag the cursor in the drawing area to rotate the view, as shown in Figure 5-46.

![Figure 5-45 Isometric view of the solid model](image)

![Figure 5-46 Rotating the view to display the model from different directions](image)

You will notice that the model is being displayed from different directions. Remember that when you rotate the view, the model is not being rotated. The camera that is used to view the model is being rotated around the model.

3. After viewing the model from all directions, press CTRL+7 from the keyboard; the model again gets oriented to the isometric view.

Modifying the Standard Views

As mentioned in the tutorial description, you need to modify the standard views such that the front view of the model becomes the top view. This is done using the Orientation dialog box.

1. Press the SPACEBAR on the keyboard; the Orientation dialog box is displayed.

2. Hold the Orientation dialog box by selecting it on the title bar of this dialog box and then drag it to the top right corner of the drawing area.

   The Orientation dialog box will close automatically if you perform any other operation. Therefore, you need to pin this dialog box.

3. Choose the Push Pin button to pin this dialog box at the top right corner of the drawing area. Pinning the dialog box ensures that the dialog box is not automatically closed when you perform any other operation.
4. Double-click on the **Front** option in the list box of the **Orientation** dialog box; the current view is automatically changed to the front view and the model is now reoriented and displayed from the front.

Now, you need to modify the standard views such that the front view of the model becomes the top view. Then, you need to save the model with the current settings.

5. Select the **Top** option from the list box by selecting it once.

Make sure you do not double-click on this option. This is because if you double-click on this option, the model will be reoriented and displayed from the top.

6. Now, choose the **Update Standard Views** button to update the standard views; the **SolidWorks** warning box is displayed and you are warned that modifying the standard views will change the orientation of any named view in this document.

7. Choose **Yes** from this warning box to modify the standard views.

8. Now, double-click on the **Isometric** option in the list box of the **Orientation** dialog box. You will notice that the isometric view is different now, refer to Figure 5-47.

9. Choose the **Push Pin** button from the **Orientation** dialog box again and left-click anywhere in the drawing area to close the dialog box.

**Saving the Model**

As the name of the document was specified at the beginning, you need to choose the save button to save the document.

1. Choose the **Save** button from the **Menu Bar** toolbar to save the document; the model is saved with the name `\My Documents\SolidWorks\c05\c05tut1.sldprt`.

2. Choose **File > Close** from the Menu Bar menus to close the document.
In this tutorial, you will create the model shown in Figure 5-48. Its dimensions are shown in Figure 5-49. The extrusion depth of the model is 20 mm. After creating the model, rotate the view and then change the view back to the isometric view before saving the model.

(Expected time: 45 min)

![Figure 5-48 Model for Tutorial 2](image)

The following steps are required to complete this tutorial:

a. Start a new SolidWorks part document and then invoke the sketching environment.
b. Create the outer loop and then create the sketch of three inner cavities. Finally, draw the six circles inside the outer loop for the holes, refer to Figures 5-50 through 5-54.
c. Invoke the **Extruded Boss/Base** tool and extrude the sketch through a distance of 20 mm, refer to Figure 5-55.
d. Rotate the view using the **Rotate View** tool.
e. Change the current view to isometric view and then save the document.

**Starting a New Part Document**
1. Choose the **New** button from the **Menu Bar** toolbar and start a new part document using the **New SolidWorks Document** dialog box.

2. Choose the **Sketch** button from the **Sketch CommandManager** and select the **Front Plane**; the sketching environment is invoked.

**Drawing the Outer Loop**
This is the same sketch that was created in the Tutorial 3 of Chapter 3. In this tutorial, you will create only the outer loop using the steps that were discussed in Chapter 3. It is recommended that you add relations and dimensions to it to make it fully defined.
1. Follow the steps that were discussed in the Tutorial 3 of Chapter 3 to create the outer loop.

2. Add dimensions to it to fully define the sketch, as shown in Figure 5-50.

![Figure 5-50 Sketch after creating the outer loop](image)

**Drawing the Sketch of the Inner Cavities**

Now, you need to draw the sketch of the inner cavities. Draw the sketch of one of the cavities and then add the required relations and dimensions to it. Next, you need to create a circular pattern of this cavity. The number of instances in the circular pattern is 3.

1. Choose the **Centerpoint Arc** tool, draw an arc with its center at the center point of the larger arc having 100 mm diameter. Make sure that the start point and endpoint of the arc are in the first quadrant.

2. Dimension this arc such that it is forced to a radius of 35 mm. Also, add the angular dimensions to the two endpoints of the arc, refer to Figure 5-51. The arc turns black, suggesting that it is fully defined.

3. Choose the arc; the **Arc PropertyManager** is displayed. Select the **For construction** check box and choose **OK**.

4. Offset the arc of 35 mm radius on both sides through a distance of 5 mm using the **Offset Entities** tool. Make sure that the **Add dimensions** and **Cap ends** check boxes are selected. Also, select the **Arc** radio button. The new arc created using the **Offset Entities** tool is black. Also, a dimension with the value 5 is placed between the two arcs, as shown in Figure 5-52.

Next, you need to create a circular pattern of the inner cavity.

5. Select the offset entities in the sketch of the inner cavity and then invoke the **Circular Pattern PropertyManager**.

6. Drag the center of the circular pattern to the center of the outer arc in the sketch.
7. Set the value 3 in the **Number** spinner of the **Parameters** rollout and then choose the **OK** button to create the circular pattern.

If the sketch is not fully defined, follow the steps 8 to step 12 given below:

8. Right-click and choose **Fully Define Sketch** from the shortcut menu; the **Fully Define Sketch PropertyManager** is displayed.

9. Select the **All entities in sketch** radio button in the **Entities to Fully Define** rollout.

10. Select the **Relations** check box to invoke the **Relations** rollout and make sure that all relations are selected.

11. Select the **Dimensions** check box to invoke the **Dimensions** rollout and select the **Baseline** option in both the **Horizontal Dimensions Scheme** and the **Vertical Dimensions Scheme** drop-down lists.

12. Choose the **Calculate** button from the **Entities to Fully Define** rollout; the sketch is fully defined. The sketch after creating the inner loop is shown in Figure 5-53. In this sketch the dimensions are removed for the purpose of clarity.

13. Draw a circle of 10 mm diameter and create a circular pattern of the circle. Then fully define the sketch by using the **Fully Define Sketch** tool, if required. This completes the sketch of the model. The final sketch of the model is shown in Figure 5-54.

**Extruding the Sketch**

The next step after creating the sketch is to extrude it. The sketch is extruded using the **Extruded Boss/Base** tool.

1. Choose the **Features** tab above the **FeatureManager design tree** to display the **Features CommandManager** and choose the **Extruded Boss/Base** tool.
The current view is changed to the trimetric view and the Extrude PropertyManager is displayed. Also, the preview of the model, created using the default values, is displayed in the drawing area.

2. Set the value of the Depth spinner to 20 and then choose the OK button to extrude the sketch.

3. Choose View Settings > Shadows In Shaded Mode from the Heads-up View toolbar to display the model with shadow.

4. Press SPACEBAR and then double-click on the Isometric option in the Orientation dialog box to change the current view to the isometric view. The complete model for Tutorial 2 is shown in Figure 5-55.

**Figure 5-53** Sketch after creating the circular pattern of the inner cavity

**Figure 5-54** Final sketch of the model

**Figure 5-55** Complete model for Tutorial 2

**Rotating the View**

Before you start rotating the view of the model, it is recommended that you turn off the display of the shadow.
1. Choose **View Settings > Shadows In Shaded Mode** from the **Heads-up View** toolbar to turn off the display of the shadow.

2. Now, right-click on the model and choose **Zoom/Pan/Rotate > Rotate** from the shortcut menu; the arrow cursor is replaced by the rotate view cursor.

3. Press the left mouse button and drag the cursor in the drawing area to rotate the view.

4. Change the current view to the isometric view using the **Orientation** dialog box.

**Saving the Model**
1. Choose the **Save** button from the **Menu Bar** toolbar and save the model with the name given below.

   \(\text{\textbackslash My Documents\SolidWorks\c05\c05\tut2.sldprt.}\)

2. Choose **File > Close** from the **Menu Bar** menus to close the document.

**Tutorial 3**

In this tutorial, you will open the sketch drawn in Exercise 3 of Chapter 4. You will then create a thin feature by revolving the sketch through an angle of 270-degrees, as shown in Figure 5-56. You will offset the sketch outward while creating the thin feature. After creating the model, you will turn on the option to display the shadows and also apply the Copper material to the model.

(Expected time: 30 min)

![Figure 5-56 Revolved model for Tutorial 3](image)

The following steps are required to complete this tutorial:

- Open the sketch of Exercise 3 of Chapter 4, refer to Figure 5-57.
- Save it in the folder of the current chapter.
- Invoke the **Revolved Boss/Base** tool and revolve the sketch through an angle of 270-degrees, refer to Figure 5-59.
d. Change the current view to isometric view and then display the model in shadow, refer to Figure 5-60.

e. Assign copper material to the model, refer to Figure 5-61.

Opening the Document of Exercise 3 of Chapter 4

As the required document is saved in the \My Documents\SolidWorks\c04 folder, you need to select this folder and then open the c04exr3.sldprt document.

1. Choose the Open button from the Menu Bar toolbar to display the Open dialog box. The c05 folder is the current folder in this dialog box.

2. Browse and select the \My Documents\SolidWorks\c04 folder. All documents that were created in Chapter 4 are displayed in this folder.

3. Select the c04exr3.sldprt document; and then choose the Open button; the document is opened in the sketching environment.

Saving the Document in the c05 Folder

As mentioned earlier, it is recommended that you save the document with a new name in the folder of the current chapter so that the original document is not modified.

1. Choose File > Save As from the Menu Bar menus to display the Save As dialog box. Because the c04 folder was selected last to open the document, it is the current folder.

2. Browse and select the c05 folder and double-click on it to make it current.

3. Enter the name of the document in the File name edit box as c05tut3. Choose the Save button to save the document. The sketch is displayed in the drawing area, as shown in Figure 5-57.

Figure 5-57 Sketch for the revolved model
Revolving the Sketch

The sketch consists of two centerlines. The first centerline was used to mirror the sketched entities and the second was drawn to apply linear diameter dimensions. You need to revolve the sketch around the second centerline.

1. Choose the Features tab above the FeatureManager design tree to display the Features CommandManager. Choose the Revolved Boss/Base button. The sketch is automatically oriented in the trimetric view and the Revolve PropertyManager is displayed.

Because the sketch has two centerlines, SolidWorks cannot determine which one to use as an axis of revolution. This is the reason why you are prompted to select the axis of revolution.

2. Select the horizontal centerline that was used to create linear diameter dimensions as the axis of revolution. The preview of a complete revolved feature in temporary shaded graphics is displayed in the drawing area. As the preview of the model is not displayed properly in the current view, you need to zoom the drawing.

3. Choose the Zoom to Fit button from the Heads-up View toolbar or press the F key on the keyboard.

4. Set the value of the Angle spinner in the Revolve PropertyManager to 270; the preview of the revolved model is also modified accordingly. If you enter the value in the Angle spinner, you need to click anywhere on the screen to make sure the preview is modified.

Note that if the horizontal centerline was drawn from left to right, then the direction of revolution has to be reversed to get the required model; refer to the right-hand thumb rule. You can reverse the direction of revolution using the Reverse Direction button available on the left of the Revolve Type drop-down list.

5. Select the Thin Feature check box to invoke the Thin Feature rollout, as shown in Figure 5-58. Set the value in the Direction 1 Thickness spinner to 5. You will notice that the preview of the thin feature is shown outside the original sketch.

6. Choose the OK button; the revolved feature is created, as shown in Figure 5-59.

7. Choose the Isometric option from the flyout that is displayed on choosing the View Orientation button from the Heads-up View toolbar.

Rotating the View

Next, you need to rotate the view so that you can view the model from all directions. As mentioned earlier, the view can be rotated using the Rotate View tool.

1. Press the middle mouse button and move the cursor; the arrow cursor is replaced by the rotate view cursor.
2. Hold the middle mouse button and drag the cursor in the drawing area to rotate the view.

3. Press SPACEBAR to invoke the Orientation dialog box. In this dialog box, double-click on the Isometric option.

**Displaying the Shadow**

As mentioned in the tutorial description, you need to display the shadow of the model if it is not displayed by default. You can turn on the display of the shadow using the Heads-up View toolbar.

1. Choose View Settings > Shadows In Shaded Mode from the Heads-up View toolbar to display the model with shadow, as shown in Figure 5-60.

**Assigning Materials to the Model**

As mentioned earlier, you can invoke this PropertyManager using the Material option in the FeatureManager design tree. Note that you can also assign a material to a model by choosing Edit > Appearance > Material from the Menu Bar menus.
1. Right-click on the Material <not specified> option in the FeatureManager design tree and choose the Edit Material option; the Materials Editor PropertyManager is displayed.

2. Click on the (+) sign located on the left of the Copper and its Alloys option from the list box in the Materials rollout; the tree view expands and the materials in this family are displayed in the tree view.

3. Select the Copper option and choose OK from the Materials Editor PropertyManager. The model, after assigning the material, is shown in Figure 5-61.

**Figure 5-61 Model after assigning the copper material**

**Saving the Model**

As the name of the document was specified at the beginning, you just need to choose the save button now to save the document.

1. Choose the Save button from the Menu Bar toolbar to save the model. If the SolidWorks warning box is displayed, choose Yes from it to rebuild the model before saving.

   The model is saved with the name \My Documents\SolidWorks\c05\c05tut3.sldprt.

2. Choose File > Close from the Menu Bar menus to close the document.

**SELF-EVALUATION TEST**

Answer the following questions and then compare them to those given at the end of this chapter:

1. In SolidWorks, a sketch is revolved using the Extrude PropertyManager. (T/F)

2. You can also specify the depth of extrusion dynamically in the preview of the extruded feature. (T/F)
3. You can invoke the drawing display tools such as Zoom to Fit while the preview of a model is displayed on the screen. (T/F)

4. If you rotate the view when the current display mode is set to Hidden Lines Visible, the hidden lines in the model are automatically displayed. (T/F)

5. The ________ tool is used to display the perspective view of a model.

6. The Cap ends check box is displayed in the Extrude PropertyManager only when the sketch for the thin base feature is ________.

7. The ________ check box is used to create a feature with different values in both directions of the sketching plane.

8. The ________ check box is used to apply automatic fillets while creating a thin feature.

9. The ________ button is used to display the shadow in the shaded mode.

10. To resume rotating the view freely after you have completed rotating it around a selected vertex, edge, or face, ________ anywhere in the drawing area.

**REVIEW QUESTIONS**

**Answer the following questions:**

1. You can also invoke the Rotate View tool by choosing the Rotate View option from the ________ that is displayed when you right-click in the drawing area.

2. When you choose the Wireframe button, all ________ lines will be displayed along with the visible lines in the model.

3. You can also modify the parallel view to perspective view by choosing ________ from the menu bar.

4. When you invoke the Extruded Boss/Base tool or the Revolved Boss/Base tool, the view is automatically changed to a ________.

5. The thin revolved features can be created using a ________ or an ________ sketch.

6. Which of the following buttons is chosen to modify the orientation of the standard views?

   (a) Update Standard Views
   (b) Reset Standard Views
   (c) None
   (d) Both
7. Which of the following buttons is not available in the View toolbar by default?

(a) Hidden Lines Removed  
(b) Hidden Lines Visible  
(c) Shaded  
(d) Perspective

8. Which of the following parameters is not displayed in the preview of the model?

(a) Depth  
(b) Draft angle  
(c) None  
(d) Both

9. If the sketch is open, it can be converted into:

(a) Thin feature  
(b) Solid feature  
(c) None  
(d) Both

10. In SolidWorks, which tool is used to make a sketch fully defined?

(a) Fully Define Sketch  
(b) Smart Dimension  
(c) None  
(d) Both

**EXERCISES**

**Exercise 1**

Create the model shown in Figure 5-62. The sketch of the model is shown in Figure 5-63. Create the sketch and dimension it using the fully define sketch option. The extrusion depth of the model is 15 mm. After creating the model, rotate the view.

(Expected time: 30 min)
Exercise 2

Create the model shown in Figure 5-64. The sketch of the model is shown in Figure 5-65. Create the sketch and dimension it using the fully define sketch option. The extrusion depth of the model is 25 mm. Modify the standard view such that the current front view of the model is displayed when you invoke the top view.

(Expected time: 30 min)

Figure 5-64 Model for Exercise 2

Figure 5-65 Sketch of the model for Exercise 2

Answers to Self-Evaluation Test