Chapter 9

Editing Features

Learning Objectives

After completing this chapter, you will be able to:

• Edit features.
• Edit sketches of the sketch based features.
• Edit the sketch plane of the sketch based features.
• Edit features using the Move/Size Features option.
• Cut, copy, and paste features and sketches.
• Copy features using the drag and drop method.
• Delete features.
• Delete bodies.
• Suppress and unsuppress features.
• Move or copy bodies.
• Reorder features.
• Roll back the model.
• Rename features.
• Create folders.
• Use the What’s Wrong functionality.
EDITING FEATURES OF THE MODEL

Editing is one of the most important aspects of the product design cycle. Almost all designs require editing during or after their creation. As discussed earlier, SolidWorks is a feature-based parametric software. Therefore, the design created in SolidWorks is a combination of individual features integrated together to form a solid model. All these features can be edited individually.

For example, Figure 9-1 shows a base plate with some drilled holes. To replace the four drilled holes with four counterbore holes, you need to perform an editing operation. For editing the holes, you need to select the hole feature and right-click; the shortcut menu will be displayed. Choose Edit Feature from the shortcut menu to invoke the Hole Specification PropertyManager. Alternatively, select the hole feature and do not move the mouse; a pop-up toolbar will be displayed. Choose Edit Feature from the pop-up toolbar to display the Hole Specification PropertyManager. Set the new parameters in the Hole Specification PropertyManager and end the feature modification. The drilled holes will be automatically replaced by the counterbore holes, as shown in Figure 9-2.

Similarly, you can also edit the reference geometry and the sketches of the sketch based features. When you modify the reference geometry, the feature created using the reference geometry is also modified. For example, if you create a feature on a plane at some angle and then edit the angle of the plane, the resulting feature will be automatically modified. In SolidWorks, you can perform editing tasks using various methods, which are discussed next.

Editing Using the Edit Feature Option

In SolidWorks, the Edit Feature option is the most commonly used method for editing. To edit a feature of the model using this option, select the feature from the FeatureManager design tree or from the drawing area. Next, right-click on it to invoke the shortcut menu and choose the Edit Feature option, as shown in Figure 9-3; a PropertyManager or dialog box will be invoked depending on the feature selected. Alternatively, select the feature and do not move the mouse; a pop-up toolbar will be displayed. Choose Edit Feature from the pop-up toolbar to display the PropertyManager. You can modify the parameters of that feature using the PropertyManager. The PropertyManager will also have the sequence number of the feature, as shown in Figure 9-4. After editing the parameters, choose the OK button to complete the feature creation; the feature will be modified automatically.
Editing Sketches of the Sketch Based Features

In SolidWorks, you can also edit the sketches of the sketch based features. To do so, select the feature from the FeatureManager design tree or from the drawing area and right-click to invoke the shortcut menu. Choose the Edit Sketch option from it; the sketching environment will be displayed. Alternatively, select the feature and do not move the mouse; a pop-up toolbar will be displayed. Choose Edit Sketch from the pop-up toolbar to display the sketching environment. Edit the sketch of the sketched feature using the sketching tools and exit the sketching environment. Choose CTRL+B to rebuild the model. You can also select the Rebuild button from the Menu Bar toolbar to exit the sketching environment and rebuild the model.

**Tip.** You can also use the (+) sign available on the left of the sketched feature to expand the sketched feature in the FeatureManager design tree. The sketch icon will be displayed. Select the sketch icon and invoke the shortcut menu. Choose the Edit Sketch option from it to enter the sketching environment to edit the sketch.

Changing the Sketch Plane of the Sketches

You can also change the sketch plane of the sketches of the sketch based features. To do so, expand the sketched feature by clicking on the (+) sign on its left in the FeatureManager design tree. Select the sketched feature in the FeatureManager design tree. Right-click to invoke the shortcut menu and choose the Edit Sketch option from it, as shown in Figure 9-5. Alternatively, choose Edit Sketch Plane from the pop-up toolbar as discussed earlier.

On choosing the Edit Sketch Plane option, the Sketch Plane PropertyManager will be displayed, as shown in Figure 9-6. The name of the current sketch plane will be displayed in the Sketch Plane/Face selection box. Now, select any other plane or face as the sketching plane and choose OK from the Sketch Plane PropertyManager; the sketch plane will be modified.
Editing by Selecting an Entity or a Feature

You can also edit a feature, reference geometry, or a sketch by selecting the feature either from the FeatureManager design tree or from the drawing area. To do so, ensure that the Instant 3D tool is invoked and then left-click on a feature in the FeatureManager design tree or in the drawing area; all the dimensions of the feature and the sketch used for creating it are displayed. Remember that the dimensions of the sketch will be displayed in black and the dimensions of the feature will be displayed in blue. Double-click on the dimension that you need to modify; the Modify dialog box will be invoked. Set the new value in the Modify dialog box and press the ENTER key or choose the Save the current value and exit the dialog button from the dialog box. You will notice that the value of the dimension is modified but the model is not modified with respect to the modified value. Therefore, you need to rebuild the model using the Rebuild option. To rebuild the model, choose the Rebuild button from the Menu Bar toolbar or press CTRL+B.

Editing Using the Instant3D Tool

In SolidWorks 2008, you can modify the feature and the sketch of the sketched feature dynamically without invoking the sketching environment. To edit the feature or its sketch, choose the Instant3D button from the Features CommandManager, if it is not chosen by default, and select any face of the feature to be modified in the drawing area; the selected face will be highlighted. Also, the handles to resize and relocate the feature will be displayed, as shown in Figure 9-7.
Editing Features

To resize the feature, move the cursor to the resize handle, press and hold the left mouse button at this location and drag the cursor; a scale will be displayed. Drag the cursor further to resize the feature. You will notice that the feature is dynamically resized. Release the left mouse button after resizing the feature. Note that while dragging the cursor, if you move the cursor on the scale, the values will be integers. If you move the cursor away from the scale, the values will be rational numbers. Figure 9-8 shows the resize handle being dragged to resize the feature and Figure 9-9 shows the resulting feature.

![Figure 9-7](image1)  Resize and relocate handles displayed on the selected feature

![Figure 9-8](image2)  Cursor dragging the resize handle to resize the feature

![Figure 9-9](image3)  Resulting feature

To rotate the feature, move the cursor to the bubble on the handle and right-click; the shortcut menu will be displayed. Choose the Show Rotate Handle option; the cursor changes to the rotate cursor and a circular path will be displayed. Drag the cursor to rotate the feature. You can drag the cursor clockwise or counterclockwise. If you drag the cursor inside the circular path, you can rotate the model in multiples of 90-degrees. However, if you drag the cursor outside the circular path, you can rotate the model at any angle. The feature will be rotated dynamically in the drawing area. Release the left mouse button, after rotating the feature to a required angle.
Note
If you rotate a sketched feature whose sketch is fully or partially defined using the relations and
dimensions, the Move Confirmation dialog box will be displayed, as shown in Figure 9-10.
This dialog box informs you that the external constraints in the feature are being moved and
prompts whether you want to delete those constraints or keep them by recalculating or make
them dangling. The relations or the dimensions that do not find the external reference after the
placement are made dangling.

While rotating the feature, if the Move Confirmation dialog box is displayed, you need to
choose either the Delete or the Keep button, based on the geometric and dimensional
conditions. Click anywhere in the drawing area to exit the rotate handle. Figure 9-11 shows
the preview of the rotating feature. Figure 9-12 shows the resulting rotated feature.

You can also change the placement plane or the sketch plane of the feature by choosing the
bubble in the relocating handle. To do so, select a face of the feature and move the cursor to
the bubble on the relocate handle. Press and hold the left mouse button on the bubble, drag
the cursor and release the left mouse button on another face. If the feature has some external
reference, the Move Confirmation dialog box will be displayed. Choose the appropriate
button in this dialog box; the feature will be relocated. Figure 9-13 shows the feature being
moved to another face. Figure 9-14 shows the resulting moved feature.

To translate the feature on the same plane, select a face of the feature and move the cursor to
the move handle. Press and hold the left mouse button on the arrow and drag the cursor.
You can also view the cross-section of a model without sectioning it. To view the cross-section of a model, choose the feature and right-click. Choose the **Live Section** option from the shortcut menu; two rings and a section plane parallel to the selected face will be displayed. Move the cursor toward the red colored ring; the cursor will change to the rotate cursor. Press and hold the left mouse button and move the cursor along the red colored ring; the section plane will be rotated about the horizontal axis and you can view the cross-section at different angles. Similarly, move the cursor about the green colored ring to view the cross-section about the vertical axis. Select the vertical arrow inside the rings and drag the cursor to relocate the live section plane vertically upward or downward. Choose the cross mark on the section plane to exit the live section.

**Editing Features and Sketches by Cut, Copy, and Paste**

SolidWorks allows you to adapt the windows functionality of cut, copy, and paste to copy and paste the features and sketches. The method of using this functionality is the same as used in other windows-based applications. To cut a feature, select the feature to cut, choose **Edit > Cut** from the Menu Bar menus or use the shortcut keys, CTRL+X; the **Confirm Delete** dialog box will be displayed. Choose the **Yes** button from this dialog box; the selected feature will be cut, but the sketch will be still displayed in the plane. This is because when you cut the feature only the selected feature will be deleted from the document. You will learn more about deleting later in this chapter. After you cut a feature, select the placement plane or the placement reference to place the feature. Choose **Edit > Paste** from the Menu Bar menus or use the shortcut keys, CTRL+V. If you cut and paste a feature that has some external reference, the **Copy Confirmation** dialog box will be displayed, prompting you to delete the external constraints or leave them dangling as shown in Figure 9-15. You need to choose the appropriate button to paste the feature.
If you copy and paste an item, the selected item will remain at its position and its copy will be pasted on the selected reference. To copy an item, select the feature or sketch. Choose **Edit > Copy** from the Menu Bar menus, or press CTRL+C. Select the reference where you want to paste the selected item and choose **Edit > Paste** from the Menu Bar menus, or press CTRL+V to paste it. You can paste the selected item any number of times. If you select another item and copy it on the clipboard, the last copied item will be deleted from the memory of the clipboard.

**Tip.** For pasting a sketched feature, a simple hole, or a hole created using the hole wizard, you have to select a plane or a planar face as the reference. For pasting chamfers and fillets, you have to select an edge, edges, or a face as the reference.

### Cutting, Copying, and Pasting Features and Sketches from One Document to the Other

You can also cut or copy the features and sketches from one document and paste them in another document. For example, if you need to copy a sketch created in the current document and paste it in a new document, then select the sketch and press CTRL+C to copy the item to the clipboard. Then, create a new document in the **Part** mode and select the plane on which you want to paste the sketch. Press CTRL+V to paste the sketch on the selected plane. Use the same procedure to copy features from one document to the other.

### Copying Features Using Drag and Drop

SolidWorks also provides you with the drag and drop functionality of Windows to copy and paste the item within the document. Press and hold the CTRL key on the keyboard. Next, select and drag that item from the drawing area or from the FeatureManager design tree. Drag the cursor to a location where you want to paste the item and release the left mouse button. If the item to be pasted is defined using the dimensions or the relations, the **Copy Confirmation** dialog box will be displayed to delete or make those constraints dangle. Figure 9-16 shows the feature being dragged and Figure 9-17 shows the resulting pasted feature.
Editing Features

Dragging and Dropping Features from One Document to the Other

You can also drag and drop features and sketches from one document to the other. To do so, you should open both the documents in the SolidWorks session. Choose Windows > Tile Vertical/Tile Horizontal from the Menu Bar menus; both the documents are displayed at the same time in the SolidWorks window. Press and hold the CTRL key on the keyboard. Select the feature or the sketch in the Feature Manager design tree in one document, drag and place it on the other document on the required entity, as shown in Figure 9-18. Note that you cannot drag and drop the base feature.

Deleting Features

You can delete the unwanted features from the model by selecting the feature from the FeatureManager design tree or from the drawing area. After selecting the feature to be deleted, choose the DELETE key on the keyboard, or right-click to invoke the shortcut menu and choose Delete from the Feature area; the Confirm Delete dialog box will be displayed, as shown in Figure 9-19. The features that are dependent on the feature to be deleted are also displayed in the Confirm Delete dialog box, which informs you that all the dependent features of the parent feature will also be deleted. If the Also delete all child features check box is selected, all the child features related to the parent feature will be also deleted. But when you delete a sketched feature, the sketches related to it will not be deleted. These sketches are known as absorbed features. To delete the absorbed features along with the parent feature, select the Also delete absorbed features check box from the Confirm Delete dialog box.
dialog box. Choose the **Yes** button to delete the selected features, choose the **No** button to cancel the delete operation. You can also delete a selected feature by choosing **Edit > Delete** from the Menu Bar menus.

### Deleting Bodies

- **CommandManager:** Features > Delete Solid/Surface (Customize to add)
- **Menu Bar:** Insert > Features > Delete Body
- **Toolbar:** Features > Delete Solid/Surface (Customize to add)

As discussed earlier, multibody environment is supported in SolidWorks. Therefore, you can create multiple disjoint bodies in SolidWorks. You can also delete the unwanted bodies. The bodies to be deleted can be solid bodies or surface bodies. To delete a body, choose **Insert > Features > Delete Body** from the Menu Bar menus. You can also invoke this tool by choosing the **Delete Solid/Surface** button from the **Features CommandManager** after customizing the **CommandManager**; the **Delete Body PropertyManager** will be displayed, as shown in Figure 9-20. You are also prompted to select the solid and/or surface bodies to be deleted.

Select the body or the bodies to be deleted from the drawing area or from the **Solid Bodies** folder available in the **FeatureManager design tree**, which is displayed in the drawing area; the selected body will be displayed in blue and its name will be displayed in the **Solid/Surface Bodies to Delete** selection box. Choose the **OK** button from the **Delete Body PropertyManager**; a new item with the name **Body-Delete1** will appear in the **FeatureManager design tree**. This item will store the deleted bodies. Therefore, at any point of your design cycle, you can delete or suppress this item to resume the deleted body back in your design. You will learn more about suppressing features later in this chapter.
Suppressing Features

Sometimes, you do not want a feature to be displayed in the model or in its drawing views. Instead of deleting those features, they can be suppressed. When you suppress a feature, it is neither visible in the model nor in the drawing views. Also, if you create an assembly using that model, the suppressed feature will not be displayed even in the assembly. You can resume such suppressed features at anytime by unsuppressing them. When you suppress a feature, the features that are dependent on it are also suppressed. To suppress a feature, select it from the FeatureManager design tree or from the drawing area. Choose the Suppress button from the Features CommandManager after customizing it, or right-click and choose the Suppress option from the shortcut menu. You can also choose Suppress from the pop-up toolbar that will be displayed on selecting a feature. The suppressed feature will be removed from the display of the model and the icon of the feature will be displayed in gray in the FeatureManager design tree.

Unsuppressing the Suppressed Features

The suppressed features can be unsuppressed using the Unsuppress tool. To resume the suppressed feature, select the suppressed feature from the FeatureManager design tree and choose the Unsuppress button. You can also choose this option from the shortcut menu or from the pop-up toolbar after selecting the suppressed feature. Note that when you resume a suppressed feature using this tool, the dependent features remain suppressed. Therefore, you need to unsuppress all the features independently.

Unsuppressing Features With Dependents

As discussed earlier, when you suppress a feature, the dependent features are also suppressed. You can resume the suppressed feature along with the dependents of the suppressed parent feature in a single click using the Unsuppress with Dependents tool. To do so, select the suppressed feature from the FeatureManager design tree. Choose the Unsuppress with Dependents button from the Features toolbar. You will observe that the dependent suppressed features are also unsuppressed.
Hiding Bodies

While working in the multibody environment, you can also hide the bodies. The hidden body is not displayed in the model, assembly, or in the drawing views. The display of the dependent bodies is also turned off when you hide a body. To hide a body, expand the Solid Bodies folder in the FeatureManager design tree, and select the body to be hidden. Right-click to invoke the shortcut menu and choose the Hide Solid Body option from it. The selected body will disappear from the drawing area. The icon of the hidden body is displayed in wireframe in the Solid Bodies folder. To turn on the display of the hidden body, select it from the Solid Bodies folder and choose the Show Solid Body option from the shortcut menu.

Moving and Copying Bodies

<table>
<thead>
<tr>
<th>CommandManager:</th>
<th>Features &gt; Move/Copy Bodies (Customize to add)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menu:</td>
<td>Insert &gt; Features &gt; Move/Copy Bodies</td>
</tr>
<tr>
<td>Toolbar:</td>
<td>Features &gt; Move/Copy Bodies (Customize to add)</td>
</tr>
</tbody>
</table>

In the multibody environment, you can also move or copy the bodies by choosing the Move/Copy Bodies button from the Features CommandManager after customizing it, or choosing Insert > Features > Move/Copy Bodies from the Menu Bar menus; the Move/Copy Body PropertyManager will be displayed. By default, it shows the Mates Settings rollout. Choose the Translate/Rotate button below the Options rollout; the Translate and Rotate rollouts will be displayed, as shown in Figure 9-21.

The Bodies to Move/Copy rollout is used to define the body to copy or move. On invoking the Move/Copy Body PropertyManager, you will be prompted to select the bodies to move/copy and set the options. Move the cursor on the body to be selected; the cursor will be replaced by the body selection cursor and the edges of the body will be highlighted. The name of the body will also be displayed in the tooltip. Select the body; it will be highlighted and a 3D triad is displayed. The name of the body will be displayed in the Solid and Surface or Graphics Bodies to Move/Copy selection box. You can also select the body from the Solid Bodies folder after expanding the FeatureManager design tree.

The Copy check box is cleared by default. Select the Copy check box to create multiple copies of the selected body. When you select this check box, the Number of Copies spinner will be displayed below the Copy check box. Set the number of copies in this spinner.

On selecting a body, you will notice that a 3D triad is displayed at the centroid of the selected body. It is used to dynamically rotate or move the selected body. The three arrows of this triad are the X, Y, and Z axes along which the body can be moved. This triad also has three rings around which the body can be rotated, see Figure 9-22.
To move a body dynamically, move the cursor close to any one of the arrows of the triad; the arrow will be highlighted and the select cursor will be replaced by the move cursor. Press and hold the left mouse button and drag the cursor to move the body. You can also move the cursor on the plane displayed between two arrows and drag the cursor to move the body in that plane.

To rotate the body, move the cursor over one of the rings; the ring will be highlighted and the cursor will be replaced by the rotate cursor. Press and hold the left mouse button and drag the cursor to rotate the body.

Other rollouts in the Move/Copy Body PropertyManager are discussed next.

**Translate Rollout**

The **Translate** rollout in the Move/Copy Body PropertyManager is used to define the translational parameters to move the selected body. Set the value of the destination in the Delta X, Delta Y, and Delta Z spinners. When you set the values, the preview of the moved body will be displayed in temporary graphics in the drawing area. You can also move or copy the selected body with respect to two points. To move or copy a body by specifying two points, select the Translation Reference (Linear Entity, Coordinate System, Vertex) selection box. The selection mode in this area becomes active. Select the vertex from which you want the translation to start. When you select the first vertex as the translation reference, the Delta X, Delta Y, and Delta Z spinners will be replaced by the To Vertex selection box. Now, the selection mode in the To Vertex selection box will be activated. Select the second translation reference. You will observe the preview of the translated body with respect to the selected points. The placement of the body also depends on the sequence of selection of the vertices. Therefore, you need to be very careful, while selecting the two vertices. Figure 9-23 shows the sequence for the selection of references and Figure 9-24 shows the resulting copied body.

You can also move the body freely in 3D space. To do so, move the cursor on the spherical ball where the three arrows meet. The cursor will be replaced by the move cursor. Drag it to move the body to a desired location in the 3D space.

**Figure 9-22** 3D triad to move and rotate the body

**Figure 9-23** Sequence of selection

**Figure 9-24** Resulting copied body
Rotate Rollout

The **Rotate** rollout in the Move/Copy Body PropertyManager is used to define the parameters to rotate the body. To expand this rollout, click once on the black arrow provided on the right of this rollout. The **Rotate** rollout is shown in Figure 9-25.

A filled square is placed at the origin when you invoke the Move/Copy Body PropertyManager. It is clearly visible, when you hide the origin by choosing Hide/Show Items > View Origins from the Heads-up View toolbar. It indicates the origin along which the selected body will be rotated. You can adjust the position of this temporary moveable origin using the **X Rotation Origin**, **Y Rotation Origin**, and **Z Rotation Origin** spinners. The **X Rotation Angle** spinner is used to set the value of the angular increment to rotate or copy the body along the X-axis, the **Y Rotation Angle** spinner is used to rotate or copy the body along the Y-axis, and the **Z Rotation Angle** spinner is used to rotate or copy the body along the Z-axis. You can also dynamically rotate the model. To do so, press and hold the left mouse button on the bubble, drag the cursor, and relocate the triad. Now, left-click on a ring and drag the cursor to rotate the model. You can drag the cursor clockwise or counterclockwise. The model will be rotated dynamically in the drawing area. Release the left mouse button after rotating the feature to the required angle.

To rotate or copy the selected body along an edge, click once in the **Rotation Reference (Linear Entity, Coordinate System, Vertex)** selection box to invoke the selection. Select the edge about which you want to rotate the selected body. When you select an edge, all the other spinners will disappear from the rollout, and the **Angle** spinner will be enabled in the **Rotate** rollout. Set the value of the angular increment in this spinner.

Instead of selecting an edge, you can also select a vertex along which the body will rotate or copy. Next, you need to specify the axis along which you want to rotate it.

Constraints

In SolidWorks, you can apply mates between the multiple bodies to place them at an appropriate location. Choose the **Constraints** button from the Move/Copy Body PropertyManager; the **Bodies to Move** and the **Mate Settings** rollouts will be displayed, as shown in Figure 9-26. You need to select the body that you want to move. The **Mate Settings** rollout helps you to position the selected body by applying mates. You will learn more about mates in the later chapters.
Reordering the Features

Reordering the features is defined as a process of changing the sequence of the features created in the model. Sometimes after creating a model, it may be required to change the order in which its features were created. For reordering the features, the features are dragged and placed before or after other features in the FeatureManager design tree.

To reorder a feature, select the feature in the FeatureManager design tree, and drag it; a bend arrow pointer will be displayed, which suggests that feature dragging is possible. Drop the feature at the required position. If you try to drag and drop the child feature above the parent feature, the reorder error pointer will be displayed and the SolidWorks warning box will be displayed. Choose OK from this warning box.

Consider a case in which you have created a rectangular block and a pattern of through holes created on its base feature, as shown in Figure 9-27. Now, if you create a shell feature and remove the top face, the front face, and the right face of the model, it will appear, as shown in Figure 9-28.

But this was not the desired result. Therefore, you need to reorder the shell feature before the holes. Select the shell feature in the FeatureManager design tree and drag it above the holes; all the features will be automatically adjusted in the new order, as shown in Figure 9-29.
Rolling Back the Feature

Rolling back the feature is defined as a process, in which you rollback the feature to an earlier stage. When you rollback a feature, it will be suppressed and you can add new features to the model in the rollback state. The newly added features are added before the features that are rolled back. While working with a multifeatured model, if you want to edit a feature that was created at the starting stage of the design cycle, it is recommended that you rollback the feature up to that stage. This is because after each editing operation, the time of regeneration will be minimized. Rolling back is done by shifting the Rollback Bar in the FeatureManager design tree.

To rollback a feature, select the Rollback Bar; it will be changed to blue and the select cursor will be replaced by the hand pointer, as shown in Figure 9-30. Drag the hand pointer to the feature up to the stage you want to rollback, and then release it. To resume the model, drag the Rollback Bar to the last feature of the model. You can also rollback the features using the Menu Bar menus. To do so, select the feature up to which you want to rollback the model and choose Edit > Rollback from the Menu Bar menus.

Figure 9-30  The Rollback Bar of the FeatureManager design tree

Tip. If you want to rollback the feature to the previous step, choose Edit > Roll to Previous from the Menu Bar menus. To rollback the entire model to its original position, choose Edit > Roll to End from the Menu Bar menus.

You can also choose the Roll Forward, Roll to Previous, or Roll to End options from the shortcut menu invoked by selecting the features placed below the Rollback Bar. These options are used to control the roll and rollback of the feature.

You can also rollback the feature using the keyboard. To do so, select the Rollback Bar and press the CTRL+ALT+Up arrow keys to roll forward. Similarly, use the CTRL+ALT+Down arrow keys to roll backward.
Renaming Features

The names of the features are displayed in the FeatureManager design tree. By default, the naming of the features is done according to the sequence in which they are created. You can also rename the features according to your convenience by selecting the feature from the FeatureManager design tree and then clicking once on the selected feature; an edit box will be displayed in the FeatureManager design tree. Enter the name of the feature and press the ENTER key or click anywhere on the screen.

Creating Folders in the FeatureManager design tree

You can also add folders in the FeatureManager design tree and the features displayed in the FeatureManager design tree are added in the folder. This is done to reduce the length of the FeatureManager. Consider a case, in which the base of the model consists of more than one feature. You can add a folder named Base Feature, and add all the features used to create the base in that folder. To add a folder in the FeatureManager design tree, select any feature in the FeatureManager design tree, right-click to invoke the shortcut menu, and choose the Create New Folder option; a new folder will be created above the selected feature. Specify the name of the folder and click anywhere on the screen. Now, you can drag and drop the features to the newly created folder. You can also rename the folder by selecting it and then clicking on it once. Now, enter its name in the edit box and press the ENTER key.

To add the selected feature in a new folder, choose Add to New Folder from the shortcut menu; a new folder will be created in the FeatureManager design tree and the selected feature will be added to the newly created folder. To delete the folder, select it, right-click and choose the Delete option from the shortcut menu. Use the options in this shortcut menu to rollback and suppress the features in the selected folder.

What’s Wrong Functionality

Sometimes a model may not be rebuilt properly after you modify a sketch or a feature because of the errors resulting from the modification. Therefore, you are provided with the What’s Wrong dialog box, as shown in Figure 9-31. The possible errors in the feature are displayed in this dialog box along with their detailed description.

![What's Wrong dialog box](image)

The Show errors check box is selected by default to display the errors in the What’s Wrong dialog box. The Show warnings check box is selected by default to display the warning messages. The Display What’s Wrong during rebuild check box is selected by default and is
used to display the errors at every rebuild of the model, unless the error is fixed. After
reading the description of the errors from this dialog box, choose the Close button to exit it.
The errors will also be displayed in the FeatureManager design tree. The FeatureManager design tree, with an error in a feature is displayed in Figure 9-32.

If there is an error in a model or in an assembly, the down arrow symbol will appear on the
left of the name of the model or the assembly in the FeatureManager design tree. If a feature
has an error, then the cross symbol will appear on the left of the feature in the FeatureManager
design tree. If there is an error in the child feature, the error symbol will appear on the left
of the parent feature and also on the name of the document in the FeatureManager design
tree. If a warning message appears for a feature, then a triangle with an exclamation mark
will appear on the left of that feature in the FeatureManager design tree.

Figure 9-32 The FeatureManager design tree with a feature having errors

Tip. You can also invoke the What's Wrong dialog box by selecting the feature
having errors from the FeatureManager design tree and choosing the What's
Wrong? option from the shortcut menu.
TUTORIALS

Tutorial 1

In this tutorial, you will create the model shown in Figure 9-33. After creating some of its features, you will dynamically modify it, and then undo the modification. The dimensions of the model are shown in Figure 9-34.

(Expected time: 30 min)

![Figure 9-33 Model for Tutorial 1](image1)

![Figure 9-34 Views and dimensions of the model for Tutorial 1](image2)
The following steps are required to complete this tutorial:

a. Create the base feature of the model by extruding the profile to a given distance, refer to Figures 9-35 and 9-36.
b. Add the fillets to the base feature, refer to Figures 9-37 and 9-38.
c. Add the shell feature to the model and remove the top face of the base feature, refer to Figures 9-39 and 9-40.
d. Dynamically modify the model, refer to Figures 9-41 through 9-43.
e. Create the cuts on the sides of the model, refer to Figure 9-44 and 9-45.
f. Add the shell feature to the model and remove the top face of the base feature, refer to Figure 9-46.
g. Create a plane at an offset distance from the Top Plane.
h. Create the standoffs using the Extrude Boss/Base and Fillet tool, and pattern the standoffs, refer to Figure 9-47.
i. Save the model.

Creating the Base Feature

You will draw the sketch of the base feature on the Front Plane and extrude it using the Mid Plane option.


2. Invoke the Extruded Boss/Base tool and draw the sketch of the base feature on the Front Plane. Add the required relations and dimensions to the sketch, as shown in Figure 9-35.

3. Extrude the sketch to a distance of 35 mm using the Mid Plane option.

The base feature of the model is shown in Figure 9-36.

Adding Fillet to the Base Feature

After creating the base feature, you will fillet its lower edges.

1. Invoke the Fillet PropertyManager, rotate the model, and select the edges of the base feature, as shown in Figure 9-37.
2. Set the value in the Radius spinner to 2.5 and choose the OK button from the Fillet PropertyManager.

The model, after adding fillet to its edges, is shown in Figure 9-38.

![Figure 9-38 Fillet added to the model](image)

**Adding Shell to the Model**

After creating the fillet feature, you need to shell the model using the Shell tool.

1. Orient the model in the isometric view and invoke the Shell1 PropertyManager.

2. Select the top planar face of the model, as shown in Figure 9-39.

3. Set the value in the Thickness spinner to 1, and choose the OK button from the Shell1 PropertyManager.

The model, after adding the shell feature, is shown in Figure 9-40.
Dynamically Editing the Features

After adding the shell feature to the base of the model you will edit the features dynamically using the **Instant3D** tool.

1. Choose the **Instant3D** button from the **Features CommandManager**, if it is not chosen already.

2. Select the front planar face of the base feature from the drawing area; the selected face is highlighted in blue and a green colored arrow is displayed.

3. Move the cursor to the green colored arrow and press and hold the left mouse button; the move cursor is displayed, as shown in Figure 9-41. Drag the cursor to resize the feature.

4. Release the left mouse button after dragging the cursor to some distance. Figure 9-42 shows the preview of the dragged feature and Figure 9-43 shows the edited feature.

---

**Figure 9-39**  
*Face to be selected*

**Figure 9-40**  
*Shell feature added to the model*

**Figure 9-41**  
*Editing handles for editing the base feature*

The preview of the resized feature and its dimensions are displayed in the drawing area. As you drag the cursor, the preview and the dimensions update automatically.

4. Release the left mouse button after dragging the cursor to some distance. Figure 9-42 shows the preview of the dragged feature and Figure 9-43 shows the edited feature.
You have edited the model dynamically by dragging, but the original depth value of the feature was 35 mm. To bring the base feature back to its original size, you need to edit the feature.

5. Select the base feature from the FeatureManager design tree or from the drawing area; all dimensions of the feature are displayed in the drawing area.

6. Double-click on the dimension that reflects the depth of the base feature and is displayed in blue; the selected dimension is displayed in the text edit box.

7. Set the value in the Dimension spinner to 35 and press the ENTER key on the keyboard.

8. Choose the Rebuild button from the Menu Bar toolbar or press CTRL+B to rebuild the model.

Creating the Cut Feature

You need to create a cut feature on the front face. Next, you need to copy the cut feature on the right planar face.

1. Use the Extruded Cut tool to create the cut feature on the front face, as shown in Figure 9-44.

2. Select the feature in the FeatureManager design tree, press and hold the CTRL key, drag the selected feature, and place it on the right planar face; the Copy Confirmation dialog box is displayed.

3. Choose the Delete button; the cut feature will be created on the right planar face.

4. Select the newly created cut feature from the FeatureManager design tree; a pop-up toolbar is displayed. Choose Edit Sketch from the pop-up toolbar.

5. Apply the suitable constraints and dimensions to make it a fully defined sketch.
6. Choose the **Rebuild** button from the **Menu Bar** toolbar or press CTRL+B to rebuild the model; the model is displayed, as shown in Figure 9-45.

![Figure 9-44 The cut feature created on the front](image)

![Figure 9-45 The model after copying the feature face](image)

7. Create the slots, add fillet, and pattern the features. The model after creating the other features is shown in Figure 9-46.

![Figure 9-46 Model after creating other features](image)

**Tip.** To create a fillet, invoke the **Fillet** tool and choose the **Add** tab in the **FilletXpert PropertyManager**. Now, choose an edge of the slot; a pop-up toolbar will be displayed. Choose **Connected to start loop, 3 edges** from the pop-up toolbar to select all vertical edges of the slot.

**Creating the Standoff**

Now, you need to create the standoff for the model. It is created by extruding a sketch drawn on a sketch plane at an offset distance from the Top Plane. You also need to specify a draft angle while creating this feature.
1. Create a reference plane at an offset distance of 10.5 mm from the Top Plane. You need to select the **Reverse direction** check box from the **Plane PropertyManager**.

2. Select the newly created sketching plane, draw the sketch of the standoff, and apply the required relations and dimensions. The sketch consists of a circle of diameter 1 mm. For other dimensions, refer to Figure 9-34.

3. Extrude the sketch using the **Up To Next** option with an outward draft angle of 10-degrees. Hide the newly created plane; the standoffs of the model are created.

4. Rotate the model and add a fillet of radius 0.25 to the base of the standoff.

The rotated and zoom view of the complete standoff is displayed in Figure 9-47.

5. Pattern the filleted standoff feature using the **Linear Pattern** tool. The isometric view of the final model is shown in Figure 9-48.

**Figure 9-47** Rotated and zoom view of the model to show the standoff

**Figure 9-48** Final model

**Saving the Model**

1. Save the model with the name and location given below:

   `\My Documents\SolidWorks\c09\c09tut1.sldprt`

2. Choose **File > Close** from the Menu Bar menus to close the document.
In this tutorial, you will create the model shown in Figure 9-49, and then edit it using the **Move/Size Features** option. The views and dimensions of the model are shown in the same figure.

(Expected time: 45 min)

**Figure 9-49** Views and dimensions of the model for Tutorial 2

The following steps are required to complete this tutorial:

a. Create the base feature of the model by revolving the sketch along the central axis of the sketch, refer to Figures 9-50 and 9-51.

b. Draw the sketch of the second feature on the top face of the base feature and extrude it to a given dimension, refer to Figures 9-52 and 9-53.

c. Create the revolve cut feature, refer to Figures 9-54 and 9-55.

d. Create the hole using the **Simple Hole** tool, and then pattern it using the **Circular Pattern** tool, refer to Figure 9-55.

e. Create a drilled hole feature using the **Hole Wizard** tool, refer to Figure 9-55.

f. Mirror the hole feature about the Right Plane, refer to Figure 9-55.

g. Apply the fillet, refer to Figure 9-55.

h. Perform the live sectioning of the model, refer to Figure 9-56.

i. Save the model.
Creating the Base Feature

First, you will create the base feature of the model by revolving the sketch created on the Front Plane.


2. Invoke the **Revolved Boss/Base** tool and draw the sketch of the base feature on the Front Plane. Add the required relations and dimensions to the sketch, as shown in Figure 9-50.

3. Exit the sketching environment.

You do not need to set any parameters in the **Revolve PropertyManager** because the default value in the **Angle** spinner is 360-degrees, as required.

4. Choose the **OK** button from the **Revolve PropertyManager**.

The base feature created after revolving the sketch is shown in Figure 9-51.

![Figure 9-50 Sketch for the base feature](image1)

![Figure 9-51 Dimetric view of the base feature](image2)

Creating the Second Feature

The second feature of this model is an extruded feature. It is created by extruding a sketch created on the top planar face of the base feature.

1. Invoke the **Extruded Boss/Base** tool and select the top planar face of the base feature as the sketching plane.

2. Draw the sketch of the second feature and apply the required relations and dimensions to it, as shown in Figure 9-52. Make sure that the sketch is symmetrical about the centerline. If it is not, the sketch will not be properly mirrored.

3. Extrude the sketch to a distance of 75 mm.

The isometric view of the model after creating the second feature is displayed in Figure 9-53.
Creating the Third Feature

The third feature of the model is created by revolving a sketch using the cut option. The sketch for this feature will be created on the Front Plane.

1. Invoke the Revolved Cut tool and select the Front Plane as the sketching plane.

2. Draw the sketch for the revolved cut feature and apply the required relations and dimensions to it, as shown in Figure 9-54.

3. Exit the sketching environment, and create a revolved cut feature with a default angle value of 360-degrees.

Creating the Remaining Features

1. Create the other features of the model using the Fillet, Simple Hole, and Hole Wizard tools, refer to Figure 9-54.

The isometric view of the model, after creating all the other features, is displayed in Figure 9-55.
Sectioning the Model

1. Choose the top planar surface of the base feature and right-click; the shortcut menu is displayed.

2. Choose the Live Section option from the shortcut menu; a sectioning plane with two rings at the centre is displayed.

3. Move the cursor to the red colored ring, press and hold the left mouse down and drag the cursor to section the model along the vertical plane. Figure 9-56 shows the live section of the model when the sectioning plane is at an angle of 90 degrees.

4. Similarly, you can rotate the sectioning plane using the green colored ring.

5. Choose the cross mark in the section plane to close the live section.

Saving the Model

Now, you need to save the model.

1. Save the model with the name and location given below:

   `\My Documents\SolidWorks\c09\c09tut2.sldprt`

2. Choose File > Close from the Menu Bar menus to close the document.
Tutorial 3

In this tutorial, you will create the model shown in Figure 9-57. While creating it, you will also perform some editing operations on it. The views and dimensions of the model are displayed in Figure 9-58.

(Expected time: 45 min)

Figure 9-57 Model for Tutorial 3

Figure 9-58 Views and dimensions of the model for Tutorial 3
The following steps are required to complete this tutorial:

a. Create a base feature of the model by revolving the sketch drawn on the Front Plane, refer to Figures 9-59 and 9-60.
b. Shell the model using the Shell tool, refer to Figure 9-61.
c. Draw the sketch on the Top Plane and extrude it to the given distance, refer to Figure 9-62.
d. Pattern the extrude feature using the Circular Pattern tool, refer to Figure 9-63.
e. Edit the circular pattern, refer to Figure 9-64.
f. Create the features on the top planar face, refer to Figures 9-63 and 9-65.
g. Create the slot on the top planar face and pattern it, refer to Figures 9-67 and 9-68.
h. Unsuppress the suppressed features and create the remaining features of the model, refer to Figures 9-67 and 9-68.
i. Save the model.

Creating the Base Feature
First, you need to create the base feature of the model by revolving the sketch created on the Front Plane.

2. Invoke the Revolved Boss/Base tool and draw the sketch of the base feature on the Front Plane. Add the required relations and dimensions to it, as shown in Figure 9-59.
3. Exit the sketching environment and create the base feature of the model, as shown in Figure 9-60.

Shelling the Base Feature
After creating the base feature, you need to shell the model using the Shell tool. You will also remove the bottom face of the base feature, leaving behind a thin walled model.

1. Invoke the Shell1 PropertyManager and set the value in the Thickness spinner to 2.5.
2. Rotate the model and select its bottom face to remove it.
3. Choose the **OK** button from the **Shell1 PropertyManager**. The model, after adding the shell feature, is displayed in Figure 9-61.

![Figure 9-61 Shell feature added to the model](image)

**Creating the Third Feature**

After adding the shell feature to the model, you need to create its third feature, which is an extruded feature. The sketch for this feature will be drawn on the Top Plane.

1. Invoke the **Extruded Boss/Base** tool and select the Top Plane as the sketching plane.

2. Orient the model in the top view.

3. Draw the sketch of the third feature and add the required relations and dimensions to the sketch, as shown in Figure 9-62.

![Figure 9-62 Sketch of the third feature](image)
4. Exit the sketching environment and extrude the sketch to a depth of 5 mm.

**Patterning the Third Feature**

You need to pattern the third feature after creating it. This feature will be patterned using the Circular Pattern tool.

1. Invoke the **Circular Pattern PropertyManager**.

2. Select the third feature from the drawing area, if it is not selected in the **Features to Pattern** selection box.

3. Left-click once in the **Pattern Axis** selection box and select the circular edge of the base feature; the preview of the pattern feature is displayed.

4. Set the value in the **Number of Instances** spinner to **6** and choose **OK** from the **Circular Pattern PropertyManager**.

The model, after creating the pattern feature, is displayed in Figure 9-63.

**Editing the Pattern Feature**

The pattern created is not the same as required, refer to Figure 9-57. As a result, you need to skip the instances that are not required.

1. Select **CirPattern1** from the **FeatureManager design tree** or any one of the pattern instances other than the parent instance from the drawing area. Right-click and choose the **Edit Feature** option from the shortcut menu.

The **CirPattern1 PropertyManager** is displayed. Currently, the number of instances in the pattern feature is **6**, but the required number of instances is **3**. Therefore, you need to edit the number of instances.

2. Expand the **Instances to Skip** rollout and left-click in the selection box in this rollout; pink colored dot is displayed in the patterned feature.

3. Move the cursor to the pink colored dot; the numbers of the instance is displayed. Left-click on the second, fourth, and sixth instances.

4. Choose the **OK** button from the **CirPattern1 PropertyManager**.

The model, after editing the features, is shown in Figure 9-64.

**Suppressing the Features**

As discussed earlier, sometimes you may need to suppress some features to reduce the complications in the model. The suppressed features are not actually deleted, but their display is turned off. When you suppress a feature, the child features associated with that feature are also suppressed.
1. Select the Extrude1 feature, which is the third feature of the model, from the FeatureManager design tree; a pop-up toolbar is displayed. Choose Suppress from the pop-up toolbar.

   The circular pattern feature is the child feature of the extrude feature. Therefore, it is also suppressed. Both features are not displayed in the drawing area. The Extrude1 and the CirPattern1 features are displayed in gray in the FeatureManager design tree, indicating that both of them are suppressed.

**Creating the Protrusion**

The next feature that you need to create is the protrusion on the top face of the base feature using the Extruded Base/Boss tool.

1. Invoke the Extruded Boss/Base tool and draw the sketch of the feature on the bottom face of the base feature and extrude it to a distance of 7.5mm, as shown in Figure 9-65.

2. Create the remaining features using the Simple Hole and Fillet tool, as shown in Figure 9-66.
Note

The protrusion should be created after creating the slot. But for the purpose of tutorial, it has been created earlier. Now, we will rollback this feature and create the slot.

Rollback the Feature
1. Select the Rollback Bar and drag it before the Extrude2 feature using the hand pointer.

Creating the Slots
Next, you need to create the slots. The sketch for this feature will be drawn on the top planar face of the base feature.

1. Invoke the Extruded Cut tool and select the top planar face of the base feature as the sketching plane.
2. Draw the sketch of the cut feature and add the required relations and dimensions to the sketch, as shown in Figure 9-67.
3. Exit the sketching environment and specify the end condition as Through All from the Cut-Extrude PropertyManager.
4. Choose the OK button from the Cut-Extrude PropertyManager.
5. Now, using the Linear Pattern tool, create a linear pattern of the cut feature. You can select the dimension 18 as the directional reference. The model, after creating the linear pattern, is shown in Figure 9-68.

Rollforward the Feature
1. Select the CirPattern1 feature from the FeatureManager design tree and right-click; the shortcut menu is displayed.
2. Choose the Roll to End option from the shortcut menu.
Unsuppressing the Features

After completing the model, you need to unsuppress the features that you suppressed earlier.

1. Press and hold the CTRL key and select all the suppressed features from the FeatureManager design tree.

2. Right-click and choose the Unsuppress option from the shortcut menu.

**Note**

On selecting only the parent suppressed feature and unsuppressing it, the child features will not be unsuppressed. Therefore, you have to select both the parent feature as well as the suppressed child features.

Instead of selecting all the parent and child suppressed features from the FeatureManager design tree, select only the parent feature, and choose Edit > Unsuppress with Dependents > All Configurations from the Menu Bar menus. You will learn more about the configurations in the later chapters.

On unsuppressing the child feature, the parent feature will be unsuppressed automatically.

The suppressed features will be restored in the model. The final model, after unsuppressing the features, is shown in Figure 9-69.

![Figure 9-69 The final model](image)

Saving the Model

1. Save the model with the name c09tut3 in the location My Documents\SolidWorks\c09.

2. Choose File > Close from the Menu Bar menus to close the document.
SELF-EVALUATION TEST

Answer the following questions and then compare them to those given at the end of this chapter:

1. You cannot edit the sketch of a sketched feature. (T/F)
2. The **Edit Feature** option is used to edit any feature. (T/F)
3. You cannot rename a feature in the **FeatureManager design tree**. (T/F)
4. You cannot edit the sketch plane of the sketch of a sketched feature. (T/F)
5. You cannot edit the sketches using the **Move/ Size Features** option. (T/F)
6. The _______ dialog box is displayed when you edit a dimension.
7. The process of changing the position of a feature in the **FeatureManager design tree** is known as ________.
8. To edit the feature or the sketch dynamically, choose the _______ button.
9. The _______ **PropertyManager** is used to move or copy the bodies.
10. The _______ dialog box is displayed when there is any error in a feature.

REVIEW QUESTIONS

Answer the following questions:

1. The _______ **PropertyManager** is invoked to delete a body.
2. You can rotate a body using the _______ **PropertyManager**.
3. The _______ key is used to copy a feature or a sketch.
4. The _______ key is used to cut a feature or a sketch.
5. When the _______ tool is active, the preview of the feature is displayed in temporary graphics while editing the sketches.
6. The _______ **PropertyManager** is displayed to edit the sketch plane of a sketch.
7. To add the selected feature in a new folder, you need to choose **Add to New Folder** from the shortcut menu. (T/F)
8. For reordering the features, select the feature in the **FeatureManager design tree** and drag the feature to the required position. (T/F)

9. The **Modify** dialog box is invoked using a single click on the dimension to modify it. (T/F)

10. If you want to modify the sketch by dragging the fully or partially defined sketch, the **Override Dims on Drag/Move** option should be selected. (T/F)

**EXERCISES**

**Exercise 1**

Create the model that is sectioned and shown in Figure 9-70. The other views and dimensions of the model are also given in the same figure. The complete model is shown in Figure 9-71.

(Expected time: 45 min)

![Figure 9-70 Views and dimensions of the model for Exercise 1](image)
Exercise 2

Create the model shown in Figure 9-72. Its dimensions are shown in Figure 9-73.

(Expected time: 30 min)
Answers to Self-Evaluation Test


Figure 9-73 Views and dimensions of the model for Exercise 2